]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-sato/poky: Remove matchbox-keyboard handling (now uneeded)
authorRichard Purdie <richard@openedhand.com>
Tue, 29 May 2007 19:07:08 +0000 (19:07 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 29 May 2007 19:07:08 +0000 (19:07 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1810 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
meta/packages/matchbox-poky/matchbox-poky_0.1.bb
meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
meta/packages/matchbox-sato/matchbox-sato_0.1.bb

index 36cfee7c61cdc4027a0b708e1a2616157e82e427..4eea748d447df3ea57b840ece76ac75014b763a9 100755 (executable)
@@ -1,24 +1,7 @@
 #!/bin/sh
 
-module_id() {
-    awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
-}
-
 SHOWCURSOR="no"
 
-## Start up machine specific input devices. Really needs to go in its own session
-case `module_id` in
-       # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
-       "Generic OMAP1510/1610/1710")
-               /usr/bin/mbinputmgr &
-               ;;
-        # qemu machines.. likely need better detection 
-       "ARM-IntegratorCP" | "ARM-Versatile PB")
-               /usr/bin/mbinputmgr &
-               #SHOWCURSOR="yes"
-               ;;
-esac
-
 ## All this should be done by themeing/xsettings.. ## 
 matchbox-desktop --icon-size 48 \
                  --icon-padding 64 \
index 64c17c58f8bfa1cb28c9a99e9bf1050a1266dd0e..f486a526cc27672f32c1a237bd33cd30bbf37375 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r21"
+PR = "r23"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
index b3bde29b4f8560137d0630339ecfa820cbb51d28..5b41cbe4a59012665d96b678c27d66e76275cd14 100755 (executable)
@@ -1,27 +1,7 @@
 #!/bin/sh
 
-module_id() {
-    awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
-}
-
 SHOWCURSOR="no"
 
-## Start up machine specific input devices. Really needs to go in its own session
-case `module_id` in
-       # On Zaurus models, zaurusd takes care of mbinputmgr for us in its hinge scripts
-       "Generic OMAP1510/1610/1710")
-               matchbox-keyboard --daemon &
-               ;;
-       "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | \
-       "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
-               matchbox-keyboard --daemon --orientation portrait &
-               ;;
-        # qemu machines.. likely need better detection 
-       "ARM-IntegratorCP" | "ARM-Versatile PB")
-               #SHOWCURSOR="yes"
-               ;;
-esac
-
 ## All this should be done by themeing/xsettings.. ## 
 matchbox-desktop &
 
index 3cda6480db59aca2643e315915dcd216fc774832..b582d88588e643198c4e9feb6728e1f0b80b03ed 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2"
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}