]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Make qemu buildable inside qemux86/qemuppc target
authorZhai Edwin <edwin.zhai@intel.com>
Thu, 11 Aug 2011 07:13:32 +0000 (15:13 +0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 17 Aug 2011 05:53:53 +0000 (22:53 -0700)
It requires libx11 and libGL(if enabled GL) for building, which introduce extra
dependence in qemuppc target. Futhermore, qemu's GL code is x86-oriented, thus
some hacks needed for building in qemupcc. For simplicity, just make qemu GL's
code for native only, so that qemu building is okay in world build.

[YOCTO #1011] got fixed.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/recipes-devtools/qemu/qemu.inc
meta/recipes-devtools/qemu/qemu_0.14.0.bb

index 85476d6d937073b6b06d7cd708ef837c38288cc5..e5414ff7f74d452e9c8893c1094b89251be6c4b6 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "open source processor emulator"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "zlib alsa-lib qemugl"
+DEPENDS = "zlib alsa-lib virtual/libx11"
 
 # QEMU_TARGETS is overridable variable
 QEMU_TARGETS ?= "arm i386 mips mipsel mips64 mips64el ppc sh4 x86_64"
@@ -40,7 +40,7 @@ do_configure_prepend_virtclass-native() {
 
 do_configure() {
     ${S}/configure --prefix=${prefix} --sysconfdir=${sysconfdir} --disable-strip ${EXTRA_OECONF}
-    chmod a+x ${S}/target-i386/beginend_funcs.sh
+    test ! -e ${S}/target-i386/beginend_funcs.sh || chmod a+x ${S}/target-i386/beginend_funcs.sh
 }
 
 do_install () {
@@ -50,7 +50,6 @@ do_install () {
        install -m 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
 }
 
-SRC_URI_append_virtclass-nativesdk = " file://glflags.patch"
 DEPENDS_virtclass-native = "zlib-native alsa-lib-native"
 DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
 RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
index de12f620727bfbb47750889955799fd98e1c23d4..055321ec3ee805781e9f42cf958dbb28f4df313e 100644 (file)
@@ -11,22 +11,36 @@ FILESDIR = "${WORKDIR}"
 SRC_URI = "\
     http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \
     file://powerpc_rom.bin \
-    file://qemu-git-qemugl-host.patch \
     file://no-strip.patch \
-    file://fix-nogl.patch \
-    file://qemugl-allow-glxcontext-release.patch \
     file://linker-flags.patch \
-    file://init-info.patch \
     file://qemu-vmware-vga-depth.patch \
-    file://enable-i386-linux-user.patch \
     file://fix-configure-checks.patch \
     file://fallback-to-safe-mmap_min_addr.patch \
     file://spice-qxl-locking-fix-for-qemu-kvm.patch \
     file://Detect-and-use-GCC-atomic-builtins-for-locking.patch \
     file://larger_default_ram_size.patch \
+    "
+
+# Only use the GL passthrough patches for native/nativesdk versions
+QEMUGLPATCHES = "\
+    file://qemu-git-qemugl-host.patch \
+    file://fix-nogl.patch \
+    file://qemugl-allow-glxcontext-release.patch \
+    file://init-info.patch \
+    file://enable-i386-linux-user.patch \
     file://qemugl-fix.patch \
     file://opengl-sdl-fix.patch \
     "
+
+SRC_URI_append_virtclass-native = "\
+    ${QEMUGLPATCHES} \
+    "
+
+SRC_URI_append_virtclass-nativesdk = "\
+    ${QEMUGLPATCHES} \
+    file://glflags.patch \
+    "
+
 SRC_URI[md5sum] = "f9d145d5c09de9f0984ffe9bd1229970"
 SRC_URI[sha256sum] = "ba21e84d7853217830e167dae9999cdbff481189c6a0bb600ac7fb7201453108"