]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake: Avoid accidentally including libacl.h
authorMike Crowe <mac@mcrowe.com>
Tue, 27 May 2014 16:28:43 +0000 (17:28 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 28 May 2014 07:19:01 +0000 (08:19 +0100)
The cmake recipe doesn't depend on libacl yet cmake will detect libacl.h
and use it by default. This risks build failures if libacl.h is unstaged
during the build and it also means that the build cmake will sometimes
support ACLs and sometimes not.

This can be avoided by setting ENABLE_ACL=0 but until the fix for
http://cmake.org/Bug/view.php?id=14866 is released we also need to set
HAVE_ACL_LIBACL_H=0.

Signed-off-by: Mike Crowe <mac@mcrowe.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb

index 638c074d6a7e61d8f217d4f883c36f5ea00e0e59..cd6b1d8845726cbdf04eccdcae16d429fa88e601 100644 (file)
@@ -14,4 +14,5 @@ SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a
 # Disable ccmake since we don't depend on ncurses
 CMAKE_EXTRACONF = "\
     -DBUILD_CursesDialog=0 \
+    -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
 "