]> code.ossystems Code Review - openembedded-core.git/commitdiff
ftrace: add trace-cmd for ftrace control and config
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 20 Aug 2010 16:24:43 +0000 (12:24 -0400)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 27 Aug 2010 12:00:06 +0000 (13:00 +0100)
Rather than manually configuring ftrace, trace-cmd was created
to provide a more user friendly interface to the tracer.

Some examples are:

 # ./trace-cmd record -e all ls /bin

Then to see the information:

 # ./trace-cmd report

To see just a subsystem:

 # ./trace-cmd record -e irq ls /bin

To list the available trace events:

 # ./trace-cmd list -e

You can also trace a single trace point with one of two methods:

 # ./trace-cmd record -e sched:sched_wakeup ls /bin

Or simply:

 # ./trace-cmd record -e sched_wakeup ls /bin

This tool also works with tracers (plugins) as well as events

 # ./trace-cmd list -p

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/packages/trace-cmd/trace-cmd_git.bb [new file with mode: 0644]

index 19d69aa2d17c74326ccc12d9d3397e296389b886..e0b46120bde59cba214f12bec9bae519d1700493 100644 (file)
@@ -123,6 +123,7 @@ SRCREV_pn-qemugl-nativesdk ??= "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
 SRCREV_pn-screenshot ??= "292"
 SRCREV_pn-table ??= "4b267533ce16656cba4104fc39dc12709c1bdddf"
 SRCREV_pn-tasks ??= "ea52d46d691c5fce4473ea4e24a35411381f3a65"
+SRCREV_pn-trace-cmd ??= "0d252224626bd6926324f023a65f20c165232891"
 SRCREV_pn-tidy ??= "e25416e1293e1074bfa6727c80527dcff5b1f3cb"
 SRCREV_pn-settings-daemon ??= "2059"
 SRCREV_pn-ubootchart ??= "10"
diff --git a/meta/packages/trace-cmd/trace-cmd_git.bb b/meta/packages/trace-cmd/trace-cmd_git.bb
new file mode 100644 (file)
index 0000000..57d54d6
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "User interface to Ftrace"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "glibc"
+
+PR = r0
+PV = "1.0.4+git${SRCPV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;protocol=git"
+S = "${WORKDIR}/git"
+
+
+do_compile() { 
+       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" prefix=${prefix}
+}
+
+do_install() {
+       oe_runmake ARCH="${ARCH}" CC="${CC}" LD="${LD}" \
+                   prefix=${prefix} DESTDIR=${D} install
+}