]> code.ossystems Code Review - openembedded-core.git/commitdiff
dnf: fix "Unable to detect release version" warning
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Fri, 18 Aug 2017 13:02:46 +0000 (16:02 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Aug 2017 22:51:39 +0000 (23:51 +0100)
The release version was actually working correctly; it only makes
the warning work properly.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch [new file with mode: 0644]
meta/recipes-devtools/dnf/dnf_2.6.3.bb

diff --git a/meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch b/meta/recipes-devtools/dnf/dnf/0001-Check-conf.releasever-instead-of-releasever.patch
new file mode 100644 (file)
index 0000000..05f3141
--- /dev/null
@@ -0,0 +1,31 @@
+From 166833a88a928a574bf9143b9b65f544be482c77 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Fri, 18 Aug 2017 15:55:15 +0300
+Subject: [PATCH] Check conf.releasever instead of releasever
+
+The substitutions may actually set the conf.releasever correctly,
+and so the check should use that instead of the passed-in function
+parameter.
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/dnf/pull/901]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ dnf/cli/cli.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dnf/cli/cli.py b/dnf/cli/cli.py
+index 2d63420c..167943b8 100644
+--- a/dnf/cli/cli.py
++++ b/dnf/cli/cli.py
+@@ -914,7 +914,7 @@ class Cli(object):
+         conf.releasever = releasever
+         subst = conf.substitutions
+         subst.update_from_etc(conf.installroot)
+-        if releasever is None:
++        if conf.releasever is None:
+             logger.warning(_("Unable to detect release version (use '--releasever' to specify "
+                              "release version)"))
+-- 
+2.14.1
+
index 51072901e4dda0ec5f7046b10193f5e5e1b45c74..3ed6a74570faed0ee03ec2d015f70fc79287a2c8 100644 (file)
@@ -10,6 +10,7 @@ SRC_URI = "git://github.com/rpm-software-management/dnf.git \
            file://0001-Do-not-prepend-installroot-to-logdir.patch \
            file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
            file://0001-Corretly-install-tmpfiles.d-configuration.patch \
+           file://0001-Check-conf.releasever-instead-of-releasever.patch \
            "
 
 SRCREV = "be2585183ec4485ee4d5e121f242d8669296f065"