]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: default to enabling EGL and GLES
authorRoss Burton <ross.burton@intel.com>
Mon, 19 Nov 2012 16:04:55 +0000 (16:04 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Nov 2012 17:00:14 +0000 (17:00 +0000)
Even on systems where Mesa has no hardware support, building the software
renderers is useful for build testing and limited functionality.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa-common.inc
meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb
meta/recipes-graphics/mesa/mesa-dri_git.bb

index 8e7137818b9af76efa021efcaacd6aceb05c515f..9e42dbfe2f877b28506725dd7584d2103be94457 100644 (file)
@@ -29,8 +29,7 @@ EXTRA_OECONF = "--disable-glu \
                 --disable-glut \
                 --enable-shared-glapi"
 
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
-PACKAGECONFIG_append_x86 = " gles egl"
+PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} egl gles"
 
 X11_DEPS = "xf86driproto glproto virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
 PACKAGECONFIG[x11] = "--enable-glx-tls,--disable-glx,${X11_DEPS}"
index fabb99d59a972a1dbc6dbdbad9078bcf09627d96..a5a592d86d6733f9fa59c4a9a3f6aa0cb09e6449 100644 (file)
@@ -1,4 +1,4 @@
 require mesa-common.inc
 require mesa-${PV}.inc
 require mesa-dri.inc
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
index 5f8697a1ddaaab397f793a8c3ab9dcc230df0cf3..e9e4a88a7fcc9737bca2ad0427f86c29a7664d4d 100644 (file)
@@ -5,4 +5,4 @@ require mesa-dri.inc
 # this needs to be lower than -1 because all mesa-dri have -1 and git version has highest PV, but shouldn't be default
 DEFAULT_PREFERENCE = "-2"
 
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"