]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: move shared PROTO_DEPS, LIB_DEPS and DEPENDS to common .inc
authorMartin Jansa <Martin.Jansa@gmail.com>
Thu, 13 Oct 2011 08:04:56 +0000 (10:04 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Oct 2011 11:18:21 +0000 (12:18 +0100)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-graphics/mesa/mesa-common.inc
meta/recipes-graphics/mesa/mesa-dri_7.11.bb
meta/recipes-graphics/mesa/mesa-dri_git.bb
meta/recipes-graphics/mesa/mesa-xlib_7.11.bb

index ee359ba03e1f483640e72275a0f9aa428d4acbf6..06ebb7508c09a3ab869daba7b824fc084e23fad0 100644 (file)
@@ -18,6 +18,11 @@ PE = "2"
 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
 S = "${WORKDIR}/Mesa-${PV}"
 
+PROTO_DEPS = "xf86driproto glproto"
+LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
+
+DEPENDS = "makedepend-native python-native ${PROTO_DEPS} ${LIB_DEPS}"
+
 PROVIDES = "virtual/libgl"
 
 # for mesa-dri and mesa-xlib
index 90873aab481e50d6de5b0f28c27a09e0a1a54864..8ab1941a36677d9891e357d0822f3886b7c1a5a0 100644 (file)
@@ -1,11 +1,8 @@
 include mesa-common.inc
 include mesa-${PV}.inc
 
-PROTO_DEPS = "xf86driproto glproto dri2proto"
-LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
-            libxml2-native"
-
-DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native python-native"
+PROTO_DEPS += "dri2proto"
+LIB_DEPS += "libdrm expat"
 
 PR = "${INC_PR}.0"
 
index c50ba15f53a239984a762f7913b5d9ddace8f0d8..10ebd1c7ade2fe11f2936044e1b4d6f1475e9fdf 100644 (file)
@@ -6,10 +6,8 @@ SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa;protocol=git \
 #           file://mesa-DRI2Swapbuffer.patch "
 S = "${WORKDIR}/git"
 
-PROTO_DEPS = "xf86driproto glproto dri2proto"
-LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
-
-DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS}"
+PROTO_DEPS += "dri2proto"
+LIB_DEPS += "libdrm expat"
 
 SRCREV = "1bf94d419805538ac23a4d0b04d31ac5e4487aca"
 PV = "7.7+git${SRCPV}"
index 44719a081e09b5cc174abb271c2a231e4a78fa35..08277ac526e75a8e663c847d5c48266e075f6cf9 100644 (file)
@@ -1,11 +1,6 @@
 include mesa-common.inc
 include mesa-${PV}.inc
 
-PROTO_DEPS = "xf86driproto glproto"
-LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes libxml2-native"
-
-DEPENDS = "${PROTO_DEPS}  ${LIB_DEPS} makedepend-native"
-
 PR = "${INC_PR}.0"
 
 EXTRA_OECONF += "--with-driver=xlib --without-gallium-drivers"