]> code.ossystems Code Review - openembedded-core.git/commitdiff
hal: Use autotools_stage_all
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:50:01 +0000 (15:50 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:50:01 +0000 (15:50 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/hal/hal.inc
meta/packages/hal/hal_0.5.11+0.5.12rc1.bb
meta/packages/hal/hal_git.bb

index d0c74e84af190e987291c2294edbd93118181c35..8c5389fe8fb1be29d8c0f174a2ddbdc3fbd34f03 100644 (file)
@@ -7,7 +7,7 @@ SRC_URI = "http://hal.freedesktop.org/releases/hal-${PV}.tar.gz"
 
 S = "${WORKDIR}/hal-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 DEPENDS = "virtual/kernel dbus-glib udev intltool intltool-native expat libusb gperf-native"
 RDEPENDS += "udev hal-info"
@@ -43,15 +43,6 @@ do_install_append() {
         install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
 }
 
-do_stage() {
-        oe_libinstall -C libhal -a -so libhal ${STAGING_LIBDIR}
-        oe_libinstall -C libhal-storage -a -so libhal-storage ${STAGING_LIBDIR}
-
-        install -d ${STAGING_INCDIR}/hal
-        install -m 0644 libhal/libhal.h ${STAGING_INCDIR}/hal
-        install -m 0644 libhal-storage/libhal-storage.h ${STAGING_INCDIR}/hal
-}
-
 # At the time the postinst runs, dbus might not be setup so only restart if running
 pkg_postinst_hal () {
        # can't do this offline
index 1d4ca592ae3fc867963ee529b30e90057361a291..f9b4f2cb7d574028f9864f7079e76e1d892281ad 100644 (file)
@@ -1,6 +1,6 @@
 require hal.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://hal.freedesktop.org/releases/hal-0.5.12rc1.tar.gz \
            file://99_hal \
index 44be44f98069a59ea9acafb3294a4ba7d307b7a6..1238094914e2dd4593675347ddf9c41792ac890e 100644 (file)
@@ -16,7 +16,7 @@ PR = "r4"
 
 S = "${WORKDIR}/git"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
                 --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
@@ -37,13 +37,6 @@ do_install_append() {
        install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
 }
 
-do_stage() {
-        autotools_stage_all
-        install -d ${STAGING_LIBDIR}
-        install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
-        install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
-}
-
 # At the time the postinst runs, dbus might not be setup so only restart if running
 pkg_postinst_hal () {
        # can't do this offline