]> code.ossystems Code Review - openembedded-core.git/commitdiff
icu-native: fix hard paths in native icu
authorAndré Draszik <adraszik@digisoft.tv>
Mon, 18 May 2015 08:06:01 +0000 (09:06 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 May 2015 20:40:12 +0000 (21:40 +0100)
The icu recipe installs icu-native twice, once in the usual location,
and once for cross builds into the path given by --with-cross-build.

This latter path is not included in the list of paths recognised by
chrpath.bbclass, hence the binaries in there retain the rpath as used
during compilation. This causes the package to not be relocateable
from sstate
[YOCTO #6851]

We use the infrastructure that is in place already, and simply set
PREPROCESS_RELOCATE_DIRS as necessary, and things start to work.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/icu/icu.inc

index f4254b5f5c60cf089067199bf8eb85e7587cbe1d..cc6f222a50a35efba1d4fcb7b3ea38f4c7faa033 100644 (file)
@@ -26,6 +26,7 @@ EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
 EXTRA_OECONF_class-native = ""
 EXTRA_OECONF_class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
 
+PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
 do_install_append_class-native() {
        mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
        cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config