]> code.ossystems Code Review - openembedded-core.git/commitdiff
pango: fix x11 DISTRO_FEATURE check
authorRoss Burton <ross.burton@intel.com>
Tue, 8 Oct 2013 14:13:22 +0000 (14:13 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 14 Oct 2013 15:54:29 +0000 (16:54 +0100)
--without-x was removed in 1.32.0, so the correct option is now --without-xft.

Also remove --disable-glibtest, as configure.ac doesn't invoke that test.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/pango/pango.inc

index ea360c7cd6fcd1347855c7fad651c3742dc63f0f..17006d386cde9832b0fdc3b078db8d0ce9a15c1e 100644 (file)
@@ -13,7 +13,7 @@ X11DEPENDS = "virtual/libx11 libxft"
 DEPENDS = "glib-2.0 fontconfig freetype zlib virtual/libiconv cairo harfbuzz"
 
 PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
-PACKAGECONFIG[x11] = "--with-x,--without-x,${X11DEPENDS}"
+PACKAGECONFIG[x11] = "--with-xft,--without-xft,${X11DEPENDS}"
 
 BBCLASSEXTEND = "native"
 DEPENDS_class-native = "glib-2.0-native cairo-native harfbuzz-native"
@@ -34,8 +34,7 @@ EXTRA_AUTORECONF = ""
 # seems to go wrong with default cflags
 FULL_OPTIMIZATION_arm = "-O2"
 
-EXTRA_OECONF = "--disable-glibtest \
-               --disable-introspection \
+EXTRA_OECONF = "--disable-introspection \
                --enable-explicit-deps=no \
                --disable-debug \
                --with-mlprefix=${MLPREFIX}"