FILES_${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/lib*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
-INC_PR = "r2"
+INC_PR = "r0"
SRC_URI = "file://opstart.patch \
file://oprofile-no-query-modules.patch \
file://oprofile-root.patch \
- file://fix-bfd-include.patch \
file://acinclude.m4"
inherit autotools
+++ /dev/null
-bfd.h now wants to include autotools generated config.h for reasoning read
-http://sourceware.org/bugzilla/show_bug.cgi?id=14243
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-Index: oprofile-0.9.7/libutil++/bfd_support.h
-===================================================================
---- oprofile-0.9.7.orig/libutil++/bfd_support.h 2011-07-04 19:25:04.000000000 -0700
-+++ oprofile-0.9.7/libutil++/bfd_support.h 2012-12-02 10:51:23.518784249 -0800
-@@ -11,6 +11,7 @@
- #ifndef BFD_SUPPORT_H
- #define BFD_SUPPORT_H
-
-+#include "config.h"
- #include "utility.h"
- #include "op_types.h"
- #include "locate_images.h"
-Index: oprofile-0.9.7/libopagent/opagent.c
-===================================================================
---- oprofile-0.9.7.orig/libopagent/opagent.c 2011-07-04 19:25:04.000000000 -0700
-+++ oprofile-0.9.7/libopagent/opagent.c 2012-12-02 10:58:10.954804150 -0800
-@@ -50,6 +50,7 @@
- * See libopagent/Makefile.am for more information.
- *******************************************************************/
-
-+#include "config.h"
- #include <stdio.h>
- #include <errno.h>
- #include <string.h>
-Index: oprofile-0.9.7/libpp/symbol.h
-===================================================================
---- oprofile-0.9.7.orig/libpp/symbol.h 2011-07-04 19:25:04.000000000 -0700
-+++ oprofile-0.9.7/libpp/symbol.h 2012-12-02 10:59:59.434809273 -0800
-@@ -18,6 +18,7 @@
- #include "format_flags.h"
- #include "op_types.h"
-
-+#include "config.h"
- #include <bfd.h>
- #include <stdint.h>
-
-Index: oprofile-0.9.7/opjitconv/debug_line.c
-===================================================================
---- oprofile-0.9.7.orig/opjitconv/debug_line.c 2011-07-04 19:25:04.000000000 -0700
-+++ oprofile-0.9.7/opjitconv/debug_line.c 2012-12-02 11:02:26.046816339 -0800
-@@ -8,6 +8,7 @@
- * @author Philippe Elie
- */
-
-+#include "config.h"
- #include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
-Index: oprofile-0.9.7/opjitconv/opjitconv.h
-===================================================================
---- oprofile-0.9.7.orig/opjitconv/opjitconv.h 2011-07-04 19:25:04.000000000 -0700
-+++ oprofile-0.9.7/opjitconv/opjitconv.h 2012-12-02 11:01:25.558813373 -0800
-@@ -26,6 +26,7 @@
- #define OP_JIT_CONV_ALREADY_DONE 5
- #define OP_JIT_CONV_TMPDIR_NOT_REMOVED 6
-
-+#include "config.h"
- #include <bfd.h>
- #include <stddef.h>
- #include <sys/stat.h>
-Upstream-Status: Pending
-
-Index: oprofile/utils/Makefile.am
-===================================================================
---- oprofile.orig/utils/Makefile.am 2005-03-31 18:20:41.000000000 +0100
-+++ oprofile/utils/Makefile.am 2008-07-02 15:14:07.000000000 +0100
-@@ -3,8 +3,15 @@
+diff --git a/utils/Makefile.am b/utils/Makefile.am
+index d34b060..dff15f9 100644
+--- oprofile.orig/utils/Makefile.am
++++ oprofile/utils/Makefile.am
+@@ -7,7 +7,7 @@ AM_LDFLAGS = @OP_LDFLAGS@
LIBS=@POPT_LIBS@ @LIBERTY_LIBS@
--bin_PROGRAMS = ophelp
-+bin_PROGRAMS = ophelp opstart
+-bin_PROGRAMS = ophelp op-check-perfevents
++bin_PROGRAMS = ophelp op-check-perfevents opstart
dist_bin_SCRIPTS = opcontrol
+ op_check_perfevents_SOURCES = op_perf_events_checker.c
+@@ -15,3 +15,10 @@ op_check_perfevents_CPPFLAGS = ${AM_CFLAGS} @PERF_EVENT_FLAGS@
+
ophelp_SOURCES = ophelp.c
ophelp_LDADD = ../libop/libop.a ../libutil/libutil.a
+
+
+install-exec-local:
+ cd $(DESTDIR)/$(bindir) && \
-+ rm -f opstop && \
-+ $(LN_S) opstart opstop
++ rm -f opstop && \
++ $(LN_S) opstart opstop
Index: oprofile/utils/opstart.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+ return 0;
+}
+
-Index: oprofile/configure.in
+Index: oprofile/configure.ac
===================================================================
---- oprofile.orig/configure.in 2008-07-02 15:13:58.000000000 +0100
-+++ oprofile/configure.in 2008-07-02 15:17:37.000000000 +0100
+--- oprofile.orig/configure.ac 2008-07-02 15:13:58.000000000 +0100
++++ oprofile/configure.ac 2008-07-02 15:17:37.000000000 +0100
@@ -16,6 +16,7 @@
AM_CONFIG_HEADER(config.h)
+++ /dev/null
-require oprofile.inc
-
-PR = "${INC_PR}.0"
-
-SRC_URI += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "8b5d1d9b65f84420bcc3234777ad3be3"
-SRC_URI[sha256sum] = "cb5b507d5dea058d223fcad3cec8ff9638a4163106afd66d176798bbd973d527"
-
-S = "${WORKDIR}/oprofile-${PV}"
-
--- /dev/null
+require oprofile.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI += "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "6d127023af1dd1cf24e15411229f3cc8"
+SRC_URI[sha256sum] = "ab45900fa1a23e5d5badf3c0a55f26c17efe6e184efcf00b371433751fa761bc"
+
+S = "${WORKDIR}/oprofile-${PV}"
+