]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpciaccess: lpci access does not depend on X
authorDamien Lespiau <damien.lespiau@intel.com>
Fri, 27 Jul 2012 11:58:12 +0000 (12:58 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 28 Jul 2012 10:16:49 +0000 (11:16 +0100)
So let's remove the X dependencies from DEPENDS and white list it in
xorg-lib-common.inc.

Signed-off-by: Damien Lespiau <damien.lespiau@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xorg-lib/libpciaccess_0.13.1.bb
meta/recipes-graphics/xorg-lib/xorg-lib-common.inc

index 178e220de9eb27d2360ebfaf61e151a4078868f4..0ec6814aad2eb00ca8b24517733de0cb99ddd225 100644 (file)
@@ -8,9 +8,7 @@ require xorg-lib-common.inc
 LICENSE = "MIT & MIT-style"
 LIC_FILES_CHKSUM = "file://COPYING;md5=de01cb89a769dc657d4c321c209ce4fc"
 
-PR = "r0"
-
-DEPENDS += "xproto virtual/libx11"
+PR = "r1"
 
 SRC_URI[md5sum] = "399a419ac6a54f0fc07c69c9bdf452dc"
 SRC_URI[sha256sum] = "27ab68f645691a4ca258dcc9d131040586e134f9233ce079794496f6264da084"
index 73a4d1d3e40eb2df02488dbe3ca431f3db3beb0d..55eaf49a388c98f3bec7766acd5405149bd3d0aa 100644 (file)
@@ -16,7 +16,7 @@ inherit autotools pkgconfig
 EXTRA_OECONF = "--enable-malloc0returnsnull --with-fop=no --without-xmlto"
 
 python () {
-        whitelist = [ "pixman" ]
+        whitelist = [ "pixman", "libpciaccess" ]
         if not d.getVar('BPN', True) in whitelist and not oe.utils.contains ('DISTRO_FEATURES', 'x11', True, False, d):
                 raise bb.parse.SkipPackage("'x11' not in DISTRO_FEATURES")
 }