]> code.ossystems Code Review - openembedded-core.git/commitdiff
gobject-introspection: Use SYSROOT_DIRS to add dirs to stage in sysroot
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>
Thu, 12 May 2016 08:37:58 +0000 (10:37 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 May 2016 12:40:49 +0000 (13:40 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gobject-introspection/gobject-introspection_1.46.0.bb

index 47102cac6fcce1e6c927e4b1f02f723c37a09219..861af5f20ffcbfbd2c84fd95f2605bfb197a7195 100644 (file)
@@ -151,13 +151,12 @@ FILES_${PN}-staticdev += "${libdir}/gobject-introspection/giscanner/*.a"
 
 # we need target versions of introspection tools in sysroot so that they can be run via qemu
 # when building introspection files in other packages
-SYSROOT_PREPROCESS_FUNCS_append_class-target += "gi_binaries_sysroot_preprocess"
+SYSROOT_DIRS_append_class-target = " ${bindir}"
 
+SYSROOT_PREPROCESS_FUNCS_append_class-target = " gi_binaries_sysroot_preprocess"
 gi_binaries_sysroot_preprocess() {
-        sysroot_stage_dir ${D}${bindir} ${SYSROOT_DESTDIR}${bindir}
-
-        # Also, tweak the binary names in introspection pkgconfig file, so that it picks up our 
-        # wrappers which do the cross-compile and qemu magic.
+        # Tweak the binary names in the introspection pkgconfig file, so that it
+        # picks up our wrappers which do the cross-compile and qemu magic.
         sed -i \
            -e "s|g_ir_scanner=.*|g_ir_scanner=${bindir}/g-ir-scanner-wrapper|" \
            -e "s|g_ir_compiler=.*|g_ir_compiler=${bindir}/g-ir-compiler-wrapper|" \