]> code.ossystems Code Review - openembedded-core.git/commitdiff
make, remake: make them properly exclude each other
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Wed, 23 Mar 2016 12:52:04 +0000 (14:52 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 26 Mar 2016 22:49:37 +0000 (22:49 +0000)
Remake and make can't be installed at the same time as they're both installing
a header file with the same name.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/distro/include/default-providers.inc
meta/recipes-devtools/make/make.inc
meta/recipes-devtools/remake/remake_4.1+dbg-1.1.bb

index ba85c78906284101f1908e7d52ab19a099afb1e1..5801b67f359b2e5d2cf11e9b695afee7f3222d16 100644 (file)
@@ -15,6 +15,8 @@ PREFERRED_PROVIDER_virtual/update-alternatives-native ?= "opkg-utils-native"
 PREFERRED_PROVIDER_virtual/libx11 ?= "libx11"
 PREFERRED_PROVIDER_virtual/base-utils ?= "busybox"
 PREFERRED_PROVIDER_xf86-video-intel ?= "xf86-video-intel"
+PREFERRED_PROVIDER_virtual/make ?= "make"
+PREFERRED_PROVIDER_virtual/make-native ?= "make-native"
 
 #
 # Default virtual runtime providers
@@ -43,7 +45,6 @@ PREFERRED_PROVIDER_opkg-native ?= "opkg-native"
 PREFERRED_PROVIDER_nativesdk-opkg ?= "nativesdk-opkg"
 PREFERRED_PROVIDER_console-tools ?= "kbd"
 PREFERRED_PROVIDER_gzip-native ?= "pigz-native"
-PREFERRED_PROVIDER_make ?= "make"
 PREFERRED_PROVIDER_udev ?= "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','eudev',d)}"
 # There are issues with runtime packages and PREFERRED_PROVIDER, see YOCTO #5044 for details
 # on this rather strange entry.
index 57ea605b97556921c2b85a90ac9fe6660c1a2d58..849b74299c5d5f6e184fb3a028f73fe41855360c 100644 (file)
@@ -8,3 +8,5 @@ SECTION = "devel"
 SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.bz2"
 
 inherit autotools gettext pkgconfig texinfo
+
+PROVIDES = "virtual/make"
index 30f29e04ea54e325de91de1ca49c85cbd80f04c1..8eab7e3a0d25f50176e24f1534460890d3fd3701 100644 (file)
@@ -15,7 +15,7 @@ DEPENDS += "readline guile"
 # By default only "gettext-minimal-native" is added
 # when inherit gettext.
 DEPENDS_class-native += "gettext-native"
-PROVIDES += "make"
+PROVIDES += "virtual/make"
 
 do_configure_prepend() {
     # remove the default LINGUAS since we are not going to generate languages