]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygobject: disable parallel install
authorKai Kang <kai.kang@windriver.com>
Wed, 19 Jun 2013 10:33:07 +0000 (06:33 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 25 Jun 2013 16:30:31 +0000 (17:30 +0100)
The installation of __glib.so is invoked by install-data-am target
which are generated by automake. installing libpyglib-2.0-python is
invoked by install-exec-am.

"make install" will firstly install libpyglib-2.0-python, then install
__glib.so, the sequence should not be broken, since _glib.so has
dependence on libpyglib-2.0-python. But when enable parallel install,
the sequence maybe break then installation fails with:
 "/usr/bin/ld: cannot find -lpyglib-2.0-python"

Disable parallel install to fix this issue.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/python/python-pygobject_2.27.91.bb

index 3dc2d994832daa042dd9e710c2ed7e5466fab70e..322521bc20679b434665296d64e5dd98cf5f8edb 100644 (file)
@@ -20,6 +20,8 @@ S = "${WORKDIR}/pygobject-${PV}"
 FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
 EXTRA_OECONF += "--disable-introspection"
 
+PARALLEL_MAKEINST = ""
+
 inherit autotools distutils-base pkgconfig
 
 # necessary to let the call for python-config succeed