]> code.ossystems Code Review - openembedded-core.git/commitdiff
liburi-perl: inherit ptest-perl
authorTim Orling <timothy.t.orling@linux.intel.com>
Sun, 4 Mar 2018 12:41:52 +0000 (04:41 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 6 Mar 2018 14:13:58 +0000 (06:13 -0800)
* Enable ptest by inheriting new ptest-perl.bbclass
* Remove t/cwd.t and t/file.t which require "-T"
  (taint) command line option as they will fail.

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/liburi-perl_1.73.bb

index 7cdf6dc61dc3178235bd587befb6bd6a3bcfb81e..49238f3df53d4d1d6b7078b8377b811573626704 100644 (file)
@@ -20,11 +20,19 @@ S = "${WORKDIR}/URI-${PV}"
 
 EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
 
-inherit cpan
+inherit cpan ptest-perl
 
 do_compile() {
        export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
        cpan_do_compile
 }
 
+do_install_prepend() {
+       # these tests require "-T" (taint) command line option
+       rm -rf ${B}/t/cwd.t
+       rm -rf ${B}/t/file.t
+}
+
+RDEPENDS_${PN}-ptest += "libtest-needs-perl"
+
 BBCLASSEXTEND = "native"