]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnupg: Update checksum, fix configure and compliation issues
authorSaul Wold <sgw@linux.intel.com>
Fri, 24 Feb 2012 18:59:20 +0000 (10:59 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 26 Feb 2012 11:45:07 +0000 (11:45 +0000)
This recipe was added, but did not have the correct
checksum information for the LIC_FILES_CHKSUM or the
SRC_URI.  Also disable Documetnation for now due to
older autotools issue.

[YOCTO #1966]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gnupg/gnupg-1.4.7/configure.patch [new file with mode: 0644]
meta/recipes-support/gnupg/gnupg_1.4.7.bb

diff --git a/meta/recipes-support/gnupg/gnupg-1.4.7/configure.patch b/meta/recipes-support/gnupg/gnupg-1.4.7/configure.patch
new file mode 100644 (file)
index 0000000..e005ac6
--- /dev/null
@@ -0,0 +1,17 @@
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: gnupg-1.4.7/configure.ac
+===================================================================
+--- gnupg-1.4.7.orig/configure.ac
++++ gnupg-1.4.7/configure.ac
+@@ -827,7 +827,6 @@ else
+   AC_SUBST(USE_NLS)
+   AC_SUBST(USE_INCLUDED_LIBINTL)
+   AC_SUBST(BUILD_INCLUDED_LIBINTL)
+-  AM_PO_SUBDIRS
+ fi
+ if test "$try_extensions" = yes || test x"$card_support" = xyes ; then
index daea5aad2ab1f64c0fe9d0b014df9876f8912dc0..f033659c2258c37c801a4ddcefc070a0f20daa99 100644 (file)
@@ -5,18 +5,18 @@ SECTION = "console/utils"
 
 LICENSE = "GPLv2"
 
-LIC_FILES_CHKSUM = "file://COPYING;md5="
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-${PV}.tar.bz2 \
            file://long-long-thumb.patch \
-           file://mips_gcc4.4.patch"
+           file://configure.patch \
+           file://mips_gcc4.4.patch \
+           file://curl_typeof_fix_backport.patch"
 
-SRC_URI[md5sum] = "dcf7ed712997888d616e029637bfc303"
-SRC_URI[sha256sum] = "a2907f4432d67894e425e48ae85785dd60ecb01658c9682bcd96f5e91043bb38"
-
-S = "${WORKDIR}/gnupg-${PV}"
+SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c"
+SRC_URI[sha256sum] = "69d18b7d193f62ca27ed4febcb4c9044aa0c95305d3258fe902e2fae5fc6468d"
 
 inherit autotools gettext
 
@@ -73,7 +73,8 @@ EXTRA_OECONF = "--disable-ldap \
                --with-bzip2=${STAGING_LIBDIR}/.. \
                --disable-selinux-support \
                 --with-readline=${STAGING_LIBDIR}/.. \
-                ac_cv_sys_symbol_underscore=yes"
+                ac_cv_sys_symbol_underscore=no \
+               "
 
 do_install () {
        autotools_do_install