]> code.ossystems Code Review - openembedded-core.git/commitdiff
prelink: Uprev prelink to latest version
authorMark Hatle <mark.hatle@windriver.com>
Fri, 24 Jun 2011 18:30:15 +0000 (13:30 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 28 Jun 2011 12:50:17 +0000 (13:50 +0100)
The latest cross-prelink version tracks the prelink r190 SVN.

Fix two minor issues as well.  If we remove the package, we would
unprelink the filesystem after the rm was finished.  This is
incorrect.. we need to do this prerm.

Move the cron and cron configuration file to a new package split.
This item is not valid for most embedded users.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/prelink/prelink/prelink.default
meta/recipes-devtools/prelink/prelink_git.bb

index 901258ed2a0d37b687a01f028993c9fa5b4dbd2a..d8802f820ae0de5c01de356678637632b01b48de 100644 (file)
@@ -2,7 +2,7 @@
 # or to yes to enable it.
 # (if you change this from yes to no prelink -ua
 # will be run next night to undo prelinking)
-PRELINKING=unknown
+PRELINKING=yes
 
 # Options to pass to prelink
 # -m   Try to conserve virtual memory by allowing overlapping
index 1eea30a5f59c3b603474997b545c5fecc8248c22..b57c1453534a60d7d92a2cdad670848cda0a490b 100644 (file)
@@ -8,9 +8,24 @@ and executables, so that far fewer relocations need to be resolved at \
 runtime and thus programs come up faster."
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
-SRCREV = "909470ee441237563d6236c505cb2d02ddc48704"
+SRCREV = "ac461e73b17253a4da25c5aafeac7193b553156c"
 PV = "1.0+git${SRCPV}"
-PR = "r2"
+PR = "r3"
+
+#
+# The cron script attempts to re-prelink the system daily -- on
+# systems where users are adding applications, this might be reasonable
+# but for embedded, we should be re-running prelink -a after an update.
+#
+# Default is prelinking is enabled.
+#
+SUMMARY_${PN}-cron = "Cron scripts to control automatic prelinking"
+DESCRIPTION_${PN}-cron = "Cron scripts to control automatic prelinking.  \
+See: ${sysconfdir}/cron.daily/prelink for configuration information."
+
+FILES_${PN}-cron = "${sysconfdir}/cron.daily ${sysconfdir}/default"
+
+PACKAGES =+ "${PN}-cron"
 
 SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;protocol=git \
            file://prelink.conf \
@@ -53,9 +68,13 @@ fi
 prelink -a
 }
 
-pkg_postrm_prelink() {
+pkg_prerm_prelink() {
 #!/bin/sh
 
+if [ "x$D" != "x" ]; then
+  exit 1
+fi
+
 prelink -au
 }