]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer: Set DEPENDS dynamically for plugins-ugly and plugins-bad
authorDrew Moseley <drew_moseley@mentor.com>
Mon, 8 Sep 2014 11:58:40 +0000 (12:58 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Sep 2014 10:29:50 +0000 (11:29 +0100)
Only add plugins-ugly or plugins-bad to the DEPENDS if they are
added to the COMMERCIAL_AUDIO_PLUGINS or COMMERCIAL_VIDEO_PLUGINS.

Signed-off-by: Drew Moseley <drew_moseley@mentor.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/gstreamer/gst-meta-base_0.10.bb
meta/recipes-multimedia/gstreamer/gstreamer1.0-meta-base.bb

index 518ab721afde08c0aff7f71e10205e4f3920b05d..039abe14fa0f121d8267e75f86abba04df94edd2 100644 (file)
@@ -1,6 +1,11 @@
 SUMMARY = "GStreamer package groups"
 LICENSE = "MIT"
-DEPENDS = "gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad"
+
+COMMERCIAL_PLUGINS = "${COMMERCIAL_AUDIO_PLUGINS} ${COMMERCIAL_VIDEO_PLUGINS}"
+DEPENDS_UGLY="${@'gst-plugins-ugly' if 'ugly' in COMMERCIAL_PLUGINS.split('-') else ''}"
+DEPENDS_BAD="${@'gst-plugins-bad' if 'bad' in COMMERCIAL_PLUGINS.split('-') else ''}"
+DEPENDS = "gstreamer gst-plugins-base gst-plugins-good ${DEPENDS_UGLY} ${DEPENDS_BAD}"
+
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
index a703d9b7a4b2222acdea113208601cdb6ef7cb1b..3ef10c3723086807fad1d97801ade1344dcb9437 100644 (file)
@@ -3,7 +3,10 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
-DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
+COMMERCIAL_PLUGINS = "${COMMERCIAL_AUDIO_PLUGINS} ${COMMERCIAL_VIDEO_PLUGINS}"
+DEPENDS_UGLY="${@'gstreamer1.0-plugins-ugly' if 'ugly' in COMMERCIAL_PLUGINS.split('-') else ''}"
+DEPENDS_BAD="${@'gstreamer1.0-plugins-bad' if 'bad' in COMMERCIAL_PLUGINS.split('-') else ''}"
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good ${DEPENDS_UGLY} ${DEPENDS_BAD}"
 
 PACKAGES = "\
     gstreamer1.0-meta-base \