]> code.ossystems Code Review - openembedded-core.git/commitdiff
beecrypt: Add based on OE.dev recipes with fixes
authorRichard Purdie <richard@openedhand.com>
Mon, 18 Aug 2008 08:02:37 +0000 (08:02 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 18 Aug 2008 08:02:37 +0000 (08:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5068 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/beecrypt/beecrypt-native_3.1.0.bb [new file with mode: 0644]
meta/packages/beecrypt/beecrypt_3.1.0.bb [new file with mode: 0644]
meta/packages/beecrypt/files/x64fix.patch [new file with mode: 0644]

diff --git a/meta/packages/beecrypt/beecrypt-native_3.1.0.bb b/meta/packages/beecrypt/beecrypt-native_3.1.0.bb
new file mode 100644 (file)
index 0000000..b056a0f
--- /dev/null
@@ -0,0 +1,9 @@
+# beecrypt-native OE build file
+# Copyright (C) 2004-2005, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require beecrypt_${PV}.bb
+S = "${WORKDIR}/beecrypt-${PV}"
+
+inherit native
+EXTRA_OECONF="--enable-shared --enable-static"
diff --git a/meta/packages/beecrypt/beecrypt_3.1.0.bb b/meta/packages/beecrypt/beecrypt_3.1.0.bb
new file mode 100644 (file)
index 0000000..947ca56
--- /dev/null
@@ -0,0 +1,17 @@
+# Beecrypt OE build file
+# Copyright (C) 2004-2005, Advanced Micro Devices, Inc.  All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Beecrypt is a general-purpose cryptography library."
+HOMEPAGE="http://sourceforge.net/projects/beecrypt"
+SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
+         file://x64fix.patch;patch=1"
+
+inherit autotools
+acpaths=""
+
+EXTRA_OECONF="--with-arch=${TARGET_ARCH} --enable-shared --enable-static"
+
+do_stage () {
+       autotools_stage_all
+}
diff --git a/meta/packages/beecrypt/files/x64fix.patch b/meta/packages/beecrypt/files/x64fix.patch
new file mode 100644 (file)
index 0000000..9ee75c1
--- /dev/null
@@ -0,0 +1,20 @@
+Index: beecrypt-3.1.0/configure.ac
+===================================================================
+--- beecrypt-3.1.0.orig/configure.ac   2008-08-16 12:08:02.000000000 +0100
++++ beecrypt-3.1.0/configure.ac        2008-08-16 12:08:26.000000000 +0100
+@@ -754,15 +754,6 @@
+ # Check where to install the libraries
+ bc_libalt=
+-case $target_os in
+-linux*)
+-  case $bc_target_arch in
+-  alpha* | powerpc64 | s390x | x86_64)
+-    bc_libalt="64"
+-    ;;
+-  esac
+-  ;;
+-esac
+ AC_SUBST(LIBALT,$bc_libalt)
+ # Generate output files.