]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemux86-64: Enable latencytop and profiling (temporary)
authorDarren Hart <dvhart@linux.intel.com>
Mon, 14 Mar 2011 23:44:06 +0000 (16:44 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Mar 2011 01:17:47 +0000 (01:17 +0000)
Fixes [YOCTO #858] and [YOCTO #859]

common-pc-64.scc in the linux-yocto meta data omits latencytop and profiling
(but common-pc.scc includes them). The right fix is in common-pc-64.inc, but
this fix gets people people unblocked until Bruce can commit the proper fix to
linux-yocto.

Signed-off-by: Darren Hart <dvhart@linux.intel.com>
CC: Bruce Ashfield <bruce.ashfield@windriver.com>
CC: Jessica Zhang <jessica.zhang@intel.com>
meta/recipes-kernel/linux/linux-yocto_git.bb

index 38fbba3646be2d5e7fbe81ec05646d73f5e5e9d7..f35d1a2bf0fd6a57c6aa29c64c614fa69d7245d6 100644 (file)
@@ -31,6 +31,10 @@ KERNEL_FEATURES="features/netfilter"
 KERNEL_FEATURES_append_qemux86=" cfg/sound"
 KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
 
+# Temporary fix for oprofile and latencytop on qemux86-64
+KERNEL_FEATURES_append_qemux86-64=" features/profiling"
+KERNEL_FEATURES_append_qemux86-64=" features/latencytop"
+
 # extra tasks
 addtask kernel_link_vmlinux after do_compile before do_install
 addtask validate_branches before do_patch after do_kernel_checkout