]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-plugins: improve .la removal
authorRoss Burton <ross@burtonini.com>
Tue, 15 Sep 2020 11:05:31 +0000 (12:05 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Sep 2020 11:08:00 +0000 (12:08 +0100)
Don't assume that the .la files are installed, because some libtool
alternatives don't install these.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/alsa/alsa-plugins_1.2.2.bb

index 52dee3012634e3236ef1eb570ac7f27f95751114..e8402a6fcb55ab078029c13ad0d42c4f35d7b050 100644 (file)
@@ -51,7 +51,7 @@ FILES_${PN} = ""
 ALLOW_EMPTY_${PN} = "1"
 
 do_install_append() {
-       rm ${D}${libdir}/alsa-lib/*.la
+       rm -f ${D}${libdir}/alsa-lib/*.la
 
        if [ "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'yes', 'no', d)}" = "yes" ]; then
                # We use the example as is. Upstream installs the file under