]> code.ossystems Code Review - openembedded-core.git/commitdiff
zip: explictly disable bzip2 support
authorMartin Jansa <martin.jansa@gmail.com>
Tue, 12 Feb 2013 04:42:12 +0000 (05:42 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 2 Mar 2013 12:54:36 +0000 (12:54 +0000)
* we don't depends on bzip2, so make sure it's not autodetected in
  sysroot

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/zip/zip.inc

index 265d9a8adb3fd5f04659b5860e5fee62c4e6ff0e..c73571ad54eb73230eb0238c26203b824382d821 100644 (file)
@@ -12,9 +12,9 @@ EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \
                'BINFLAGS=0755' 'INSTALL_D=install -d'"
 
 do_compile() {
-       oe_runmake -f unix/Makefile flags
+       oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory
        sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags
-       oe_runmake -f unix/Makefile generic
+       oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory
 }
 
 do_install() {