]> code.ossystems Code Review - openembedded-core.git/commitdiff
puzzles: switch svn for git, as upstream has done the same
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Wed, 8 Jul 2015 14:30:52 +0000 (17:30 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 16 Aug 2015 16:28:12 +0000 (17:28 +0100)
Also, drop puzzles_x32_abi_time.patch as it has been merged upstream

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-sato/puzzles/files/puzzles_x32_abi_time.patch [deleted file]
meta/recipes-sato/puzzles/puzzles_git.bb [moved from meta/recipes-sato/puzzles/puzzles_r10286.bb with 87% similarity]

diff --git a/meta/recipes-sato/puzzles/files/puzzles_x32_abi_time.patch b/meta/recipes-sato/puzzles/files/puzzles_x32_abi_time.patch
deleted file mode 100644 (file)
index 63ab0b8..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Fix printf's for time_t value add castings because ISOC90
-don't support long long int that is used in x32 ABI for 
-time_t.
-
-Upstream-Status: Backport
-
-Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com>
-
---- a/magnets.c        2015-03-15 11:57:39.106674811 +0000
-+++ b/magnets.c        2015-03-15 11:57:58.638674795 +0000
-@@ -2562,7 +2562,7 @@
-         goto done;
-     }
-     s = new_game(NULL, p, desc);
--    printf("%s:%s (seed %ld)\n", id, desc, seed);
-+    printf("%s:%s (seed %ld)\n", id, desc, (long) seed);
-     if (aux) {
-         /* We just generated this ourself. */
-         if (verbose || print) {
---- a/signpost.c       2015-03-15 11:58:52.866674751 +0000
-+++ b/signpost.c       2015-03-15 11:59:08.190674738 +0000
-@@ -2393,7 +2393,7 @@
-         }
-     }
--    sprintf(newseed, "%lu", time(NULL));
-+    sprintf(newseed, "%lu", (unsigned long) time(NULL));
-     seedstr = dupstr(newseed);
-     if (id || !stdin_desc) {
similarity index 87%
rename from meta/recipes-sato/puzzles/puzzles_r10286.bb
rename to meta/recipes-sato/puzzles/puzzles_git.bb
index 1ad8d1bf1405be3f7dc5852b7ef84e38abb8d7cd..11e922511ce40f5308db61f88a83df7140ac8344 100644 (file)
@@ -2,7 +2,6 @@ SUMMARY = "Simon Tatham's Portable Puzzle Collection"
 HOMEPAGE = "http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
 
 DEPENDS = "gtk+ libxt"
-MOD_PV = "${@d.getVar('PV',1)[1:]}"
 
 # The libxt requires x11 in DISTRO_FEATURES
 REQUIRED_DISTRO_FEATURES = "x11"
@@ -10,12 +9,14 @@ REQUIRED_DISTRO_FEATURES = "x11"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=33bcd4bce8f3c197f2aefbdbd2d299bc"
 
-SRC_URI = "svn://svn.tartarus.org/sgt;module=puzzles;rev=${MOD_PV} \
+SRC_URI = "git://git.tartarus.org/simon/puzzles.git \
            file://fix-compiling-failure-with-option-g-O.patch \
-           file://puzzles_x32_abi_time.patch \
 "
+SRCREV = "c296301a06ce49b87c954c9d15452521dfeddf1a"
+PE = "1"
+PV = "0.0+git${SRCPV}"
 
-S = "${WORKDIR}/${BPN}"
+S = "${WORKDIR}/git"
 
 inherit autotools-brokensep distro_features_check