]> code.ossystems Code Review - openembedded-core.git/commitdiff
moblin-web-browser: Fix locked down patch
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 17 Aug 2009 08:24:51 +0000 (09:24 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 17 Aug 2009 08:24:51 +0000 (09:24 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-a3ea71159bef93dc03762195bd5404a51db5e4a6.patch [moved from meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch with 61% similarity]
meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb

similarity index 61%
rename from meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch
rename to meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-a3ea71159bef93dc03762195bd5404a51db5e4a6.patch
index a8675868a3ae8e0dfe31f5079c1221c0ba791f05..e920b50eeb7f2e9995288b20df41c7db75355a2c 100644 (file)
@@ -1,9 +1,9 @@
 Index: git/configure.ac
 ===================================================================
---- git.orig/configure.ac      2009-06-10 15:01:55.000000000 +0100
-+++ git/configure.ac   2009-06-10 15:19:36.000000000 +0100
-@@ -36,6 +36,13 @@
- MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul-unstable`"/unstable"
+--- git.orig/configure.ac      2009-06-23 17:46:31.000000000 +0100
++++ git/configure.ac   2009-06-23 17:46:48.000000000 +0100
+@@ -44,6 +44,13 @@
+ MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul`""
  AC_SUBST([MOZIDLDIR])
  
 +IDLPREFIX=
@@ -18,18 +18,18 @@ Index: git/configure.ac
  AC_OUTPUT([
 Index: git/libmwbpages/Makefile.am
 ===================================================================
---- git.orig/libmwbpages/Makefile.am   2009-06-10 15:01:55.000000000 +0100
-+++ git/libmwbpages/Makefile.am        2009-06-10 15:20:12.000000000 +0100
-@@ -23,10 +23,10 @@
- mwb-start-page.lo : MwbIStartPage.h
+--- git.orig/libmwbpages/Makefile.am   2009-06-23 17:46:31.000000000 +0100
++++ git/libmwbpages/Makefile.am        2009-06-23 17:47:46.000000000 +0100
+@@ -27,10 +27,10 @@
+ mwb-gettext.lo : MwbIGettext.h
  
- MwbIStartPage.h : MwbIStartPage.idl
+ .idl.h :
 -      $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m header $<
 +      xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m header $<
  
- MwbIStartPage.xpt : MwbIStartPage.idl
+ .idl.xpt :
 -      $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $<
 +      xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $<
  
xpt_DATA = MwbIStartPage.xpt
dist_xpt_DATA = MwbIStartPage.xpt MwbIGettext.xpt
  xptdir = $(MOZHOME)/components
index 63b00640d012a0fc961798e4d92436c47916a98e..cbc3e2dae0a2cee0515501a57914a4a5869971a3 100644 (file)
@@ -1,10 +1,10 @@
 DESCRIPTION = "Moblin web browser (based on clutter + mozilla-headless/mozilla-offscreen)"
 SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
-           file://xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch;patch=1;rev=b55d523da7681febfabf9fc40dcd6fcee982b079 \
-           file://xpidl.patch;patch=1;notrev=b55d523da7681febfabf9fc40dcd6fcee982b079"
+           file://xpidl-a3ea71159bef93dc03762195bd5404a51db5e4a6.patch;patch=1;rev=a3ea71159bef93dc03762195bd5404a51db5e4a6 \
+           file://xpidl.patch;patch=1;notrev=a3ea71159bef93dc03762195bd5404a51db5e4a6"
 LICENSE = "LGPLv2.1"
 PV = "0.0+git${SRCPV}"
-PR = "r7"
+PR = "r8"
 
 DEPENDS = "clutter-1.0 clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless mutter-moblin"