]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-environment: don't mark tasks as nostamp
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 19 Dec 2014 11:41:43 +0000 (11:41 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 21 Dec 2014 12:37:18 +0000 (12:37 +0000)
With siggen being changed to alter the signature of nostamp tasks on the
fly, having these tasks as nostamp results in the SDK being rebuilt
every time, which is not desirable. In any case this is just legacy from
the days before we used signatures to take care of ensuring these tasks
get re-run when they need to be.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/meta-environment.bb

index bb208a39aabdeee8797cc6e88bbfbb89edffa560..b3737bb5cf5afc0dcc10f38c56b7d2a83a135441 100644 (file)
@@ -19,7 +19,6 @@ SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${REAL_MULTIMACH_TARGET_SYS}"
 
 inherit cross-canadian
 
-do_generate_content[nostamp] = "1"
 do_generate_content[cleandirs] = "${SDK_OUTPUT}"
 do_generate_content[dirs] = "${SDK_OUTPUT}/${SDKPATH}"
 python do_generate_content() {
@@ -58,7 +57,6 @@ create_sdk_files() {
        toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${REAL_MULTIMACH_TARGET_SYS}
 }
 
-do_install[nostamp] = "1"
 do_install() {
     install -d ${D}/${SDKPATH}
     install -m 0644 -t ${D}/${SDKPATH} ${SDK_OUTPUT}/${SDKPATH}/*