]> code.ossystems Code Review - openembedded-core.git/commitdiff
coreutils: Fix build on uclibc
authorKhem Raj <raj.khem@gmail.com>
Wed, 3 Aug 2011 21:12:30 +0000 (14:12 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Aug 2011 16:12:59 +0000 (17:12 +0100)
coreutils has getloadavg.m4 of its own. So we need
to make sure that we remove the portions which look
into hardcoded /usr/local/lib paths. These tests are
only for AIX so we dont lose much

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch [new file with mode: 0644]
meta/recipes-core/coreutils/coreutils_8.12.bb

diff --git a/meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch b/meta/recipes-core/coreutils/coreutils-8.12/remove-usr-local-lib-from-m4.patch
new file mode 100644 (file)
index 0000000..aac097a
--- /dev/null
@@ -0,0 +1,31 @@
+We have problem using hardcoded directories like /usr/local here
+which will be checked for cross builds. This is a special case which
+is valid for AIX only. We do not have AIX as one of our supported
+build host or target. Therefore we get rid of the hardcoded paths
+and make life easier for cross compilation process.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [Upstream does care for AIX while we may not]
+
+Index: coreutils-8.12/m4/getloadavg.m4
+===================================================================
+--- coreutils-8.12.orig/m4/getloadavg.m4       2011-08-03 14:03:59.982197767 -0700
++++ coreutils-8.12/m4/getloadavg.m4    2011-08-03 14:04:20.402197763 -0700
+@@ -44,16 +44,6 @@ AC_CHECK_FUNC([getloadavg], [],
+        [LIBS="-lutil $LIBS" gl_have_func=yes])
+    fi
+-   if test $gl_have_func = no; then
+-     # There is a commonly available library for RS/6000 AIX.
+-     # Since it is not a standard part of AIX, it might be installed locally.
+-     gl_getloadavg_LIBS=$LIBS
+-     LIBS="-L/usr/local/lib $LIBS"
+-     AC_CHECK_LIB([getloadavg], [getloadavg],
+-                  [LIBS="-lgetloadavg $LIBS" gl_have_func=yes],
+-                  [LIBS=$gl_getloadavg_LIBS])
+-   fi
+-
+    # Set up the replacement function if necessary.
+    if test $gl_have_func = no; then
+      AC_LIBOBJ([getloadavg])
index 00746b908a3ac77c35ecdf85795dafd962cc4f54..0004ce7fc8b5d360f22aea72e1b8e4fd174ec9c7 100644 (file)
@@ -7,13 +7,15 @@ BUGTRACKER = "http://debbugs.gnu.org/coreutils"
 LICENSE = "GPLv3+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
                     file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
-PR = "r2"
+PR = "r3"
 DEPENDS = "gmp"
 DEPENDS_virtclass-native = ""
 
 inherit autotools gettext
 
-SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz \
+           file://remove-usr-local-lib-from-m4.patch \
+          "
 
 SRC_URI[md5sum] = "fce7999953a67243d00d75cc86dbcaa6"
 SRC_URI[sha256sum] = "9e233a62c98a3378a7b0483d2ae3d662dbaf6cd3917d3830d3514665e12a85c8"