]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg-native: Don't install update-alternatives as it isn't cross rootfs capable
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 10:44:42 +0000 (11:44 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 11 Oct 2010 10:44:42 +0000 (11:44 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/recipes-devtools/dpkg/dpkg.inc
meta/recipes-devtools/dpkg/dpkg_1.15.8.5.bb

index 01d591fe83a5c2e3d8f8f6301c947d5e004e2de6..59da5dc9fad84d86acbe7c37f1be544481dbc957 100644 (file)
@@ -1,7 +1,6 @@
 DESCRIPTION = "Package maintenance system for Debian."
 LICENSE = "GPL"
 SECTION = "base"
-PR = "r1"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.bz2 \
            file://ignore_extra_fields.patch;patch=1"
index 760ecd323944d7af715532f61c6dc07291540770..c8069fe18b410f8ea7905571225f4fd4ad6b3d74 100644 (file)
@@ -4,6 +4,8 @@ SRC_URI += "file://noman.patch;patch=1 \
             file://check_snprintf.patch \
             file://check_version.patch"
 
+PR = "r3"
+
 EXTRA_OECONF = "--without-static-progs \
                --without-dselect \
                --with-start-stop-daemon \
@@ -13,3 +15,7 @@ EXTRA_OECONF = "--without-static-progs \
                --without-sgml-doc"
 
 BBCLASSEXTEND = "native"
+
+do_install_append_virtclass-native () {
+       rm ${D}${bindir}/update-alternatives
+}