]> code.ossystems Code Review - openembedded-core.git/commitdiff
icu-dbg: improve reproducibility
authorJuro Bystricky <juro.bystricky@intel.com>
Sun, 7 Jan 2018 16:59:18 +0000 (08:59 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 8 Jan 2018 08:45:33 +0000 (08:45 +0000)
Make sure build host references do not end up being compiled in the image.
This only affects libicutu and icu-dbg.

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/icu/icu.inc

index 3fb16b0f682176f71480aa94cd44a6bc5eaf6a42..5cf7b11d59acb5ae39bd4de43946447f9199e7a7 100644 (file)
@@ -38,6 +38,15 @@ do_configure_prepend_libc-musl () {
     sed -i -e 's,DU_HAVE_STRTOD_L=1,DU_HAVE_STRTOD_L=0,' ${S}/configure.ac
 }
 
+do_compile_prepend_class-target () {
+       # Make sure certain build host references do not end up being compiled
+       # in the image. This only affects libicutu and icu-dbg
+       sed  \
+           -e 's,DU_BUILD=,DU_BUILD_unused=,g' \
+           -e '/^CPPFLAGS.*/ s,--sysroot=${STAGING_DIR_TARGET},,g' \
+           -i ${B}/tools/toolutil/Makefile
+}
+
 PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
 do_install_append_class-native() {
        mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config