]> code.ossystems Code Review - openembedded-core.git/commitdiff
package_ipk: There is no longer any need to force owners/groups to root
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Nov 2011 14:18:06 +0000 (14:18 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Nov 2011 16:50:59 +0000 (16:50 +0000)
Since the packaging process is run under pseudo, the default user
is now root so there is no longer any need to hardcode this. Also
take this opportunity to move the variable to package_ipk.bbclass
since this is the only user of it.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/package_ipk.bbclass
meta/conf/bitbake.conf

index c0893a6cdac6c8abae3255e56a498ce9ebecfb7e..c97e36eeb2d1206ce0162eb7ff8f74cb1662991e 100644 (file)
@@ -7,6 +7,9 @@ IPKGCONF_SDK =  "${WORKDIR}/opkg-sdk.conf"
 
 PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
 
+# Program to be used to build opkg packages
+OPKGBUILDCMD ??= "opkg-build"
+
 python package_ipk_fn () {
        bb.data.setVar('PKGFN', bb.data.getVar('PKG',d), d)
 }
index d0235bae09d170496032d20bd614c757e2f0121f..9938a676a5a025827d5224e0fae7c8978b5aa930 100644 (file)
@@ -622,10 +622,6 @@ MKTEMPCMD = "mktemp -q ${TMPBASE}"
 
 export PATCH_GET="0"
 
-# Program to be used to build opkg packages
-
-OPKGBUILDCMD = "opkg-build -o 0 -g 0"
-
 ##################################################################
 # Not sure about the rest of this yet.
 ##################################################################