]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xf86: Split xorg.conf from main xserver package
authorRichard Purdie <rpurdie@linux.intel.com>
Sun, 31 May 2009 21:17:58 +0000 (22:17 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Sun, 31 May 2009 21:17:58 +0000 (22:17 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/xorg-xserver/xserver-xf86-common.inc
meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf [moved from meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf with 76% similarity]
meta/packages/xorg-xserver/xserver-xf86-config/xorg.conf [moved from meta/packages/xorg-xserver/xserver-xf86-dri-lite/xorg.conf with 100% similarity]
meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb [new file with mode: 0644]
meta/packages/xorg-xserver/xserver-xf86-dri-lite_1.6.0.bb
meta/packages/xorg-xserver/xserver-xf86-dri-lite_git.bb

index 5a10ecf994d5371e5f98948ad7cd8ada7bb7ac7c..f69efc8d677de0212a2045d3b5c0109451d20fdb 100644 (file)
@@ -11,8 +11,7 @@ PROVIDES = "virtual/xserver-xf86"
 PROVIDES += "virtual/xserver"
 
 XORG_PN = "xorg-server"
-SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
-           file://xorg.conf"
+SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
@@ -20,6 +19,8 @@ inherit autotools_stage pkgconfig
 
 PACKAGES =+ "${PN}-utils"
 
+RDEPENDS_${PN} += "xserver-xf86-config"
+
 FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
 FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so ${libdir}/xorg/modules/*/*.so ${libdir}/xorg/modules/*/*/*.so /etc/X11 "
 FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
@@ -29,13 +30,9 @@ FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
                    ${libdir}/xorg/modules/*/*/.debug \
                    "
 
-CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
-
 SRC_URI += "file://macro_tweak.patch;patch=1"
 
 do_install_append () {
-       install -d ${D}/${sysconfdir}/X11
-       install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
        ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
 }
 
similarity index 76%
rename from meta/packages/xorg-xserver/xserver-xf86-lite/xorg.conf
rename to meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf
index 44a530e0f97a5826939748e1808c01e3e5aa1263..da7f37cebe4bb4844dd012412e37a89e9b3efc7b 100644 (file)
@@ -35,16 +35,8 @@ Section "InputDevice"
     Identifier    "stylus"
     Option        "Device"    "/dev/input/wacom"
     Option        "Type"        "stylus"
-    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
 EndSection
 
-Section "InputDevice"
-    Driver        "wacom"
-    Identifier    "eraser"
-    Option        "Device"    "/dev/input/wacom"
-    Option        "Type"        "eraser"
-    Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
-EndSection
 
 Section "InputDevice"
     Driver        "wacom"
@@ -55,9 +47,8 @@ Section "InputDevice"
 EndSection
 
 Section "Device"
-    Identifier    "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
-    Driver        "intel"
-    BusID        "PCI:0:2:0"
+    Identifier    "Graphics Controller"
+    Driver        "vmware"
 EndSection
 
 Section "Monitor"
@@ -67,7 +58,7 @@ EndSection
 
 Section "Screen"
     Identifier    "Default Screen"
-    Device        "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
+    Device        "Graphics Controller"
     Monitor        "Generic Monitor"
     DefaultDepth    24
 EndSection
@@ -79,7 +70,7 @@ Section "ServerLayout"
     InputDevice    "Configured Mouse"
 
 # Uncomment if you have a wacom tablet
-#    InputDevice     "stylus"    "SendCoreEvents"
+    InputDevice     "stylus"    "SendCoreEvents"
 #    InputDevice     "cursor"    "SendCoreEvents"
 #    InputDevice     "eraser"    "SendCoreEvents"
     InputDevice    "Synaptics Touchpad"
diff --git a/meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb b/meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb
new file mode 100644 (file)
index 0000000..db2f199
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "X.Org X server configuration file"
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/base"
+LICENSE = "MIT-X"
+
+SRC_URI = "file://xorg.conf"
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_install () {
+       install -d ${D}/${sysconfdir}/X11
+       install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+}
+
index cb23720078a616dc41d00ad44c5df5f9a29d2593..75f990ec4132d36ee447b4662bb4fd2f5016da0e 100644 (file)
@@ -1,7 +1,7 @@
 require xserver-xf86-dri-lite.inc
 
 PE = "1"
-PR = "r0"
+PR = "r1"
 
 PROTO_DEPS += "xf86driproto dri2proto"
 
index 5e08bd5dbd855307df3196a5915d25dd9cfb3a08..73ccdd452286e4231d9ad6ae3cd0d790394a2623 100644 (file)
@@ -1,7 +1,7 @@
 require xserver-xf86-dri-lite.inc
 
 PE = "1"
-PR = "r4"
+PR = "r5"
 PV = "1.5.99.1+git${SRCREV}"
 
 PROTO_DEPS += "xf86driproto dri2proto"