]> code.ossystems Code Review - openembedded-core.git/commitdiff
ncurses: enable-pc-files requires PKG_CONFIG_LIBDIR existed
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 23 Sep 2014 04:31:39 +0000 (21:31 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 10 Oct 2014 17:17:53 +0000 (18:17 +0100)
Fixed ncurses.do_configure:
configure: WARNING: did not find library /path/to/tmp/sysroots/qemuarm/usr/lib/pkgconfig

And then anyone requires ncurses.pc will fail.

The configure.in checks:
[snip]
if test -n "$PKG_CONFIG_LIBDIR" && test -d "$PKG_CONFIG_LIBDIR" ; then
[snip]

Create PKG_CONFIG_LIBDIR in do_configure will fix the problem.

We can reproduce the problem by:
Set SSTATE_DIR=/path/to/sstate-cache
1) In build1, make sure everything is ready in SSTATE_DIR
$ bitbake ncurses
2) In build2, rebuild ncurses only:
$ bitbake ncurses -ccleansstate && bitbake ncurses

Then we will see the warning in log.do_configure.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/ncurses/ncurses.inc

index 521d0e435cc5507c7f4947613e20629e935a3972..10f7dd175da9ec2a50ee0220fc955121c7de559d 100644 (file)
@@ -98,6 +98,8 @@ do_configure() {
         # not the case for /dev/null redirections)
         export cf_cv_working_poll=yes
 
+       # The --enable-pc-files requires PKG_CONFIG_LIBDIR existed
+       mkdir -p ${PKG_CONFIG_LIBDIR}
        ( cd ${S}; gnu-configize --force )
        ncurses_configure "narrowc" || \
                return 1