]> code.ossystems Code Review - openembedded-core.git/commitdiff
nettle: do the multilib_header magic for nettle-stdint.h and version.h
authorChangqing Li <changqing.li@windriver.com>
Tue, 5 Jun 2018 07:58:36 +0000 (15:58 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 15 Jun 2018 10:09:40 +0000 (11:09 +0100)
add multilib support for this receipe, or it will conflicts in mutlilib setting

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/nettle/nettle_3.4.bb

index 7a3cc654c8060929bb365e5729a5214e44a0cd04..ca8450ea990a3cd97476231c8d527b760ea85603 100644 (file)
@@ -25,7 +25,7 @@ SRC_URI[sha256sum] = "ae7a42df026550b85daca8389b6a60ba6313b0567f374392e54918588a
 
 UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
 
-inherit autotools ptest
+inherit autotools ptest multilib_header
 
 EXTRA_AUTORECONF += "--exclude=aclocal"
 
@@ -35,6 +35,10 @@ do_compile_ptest() {
         oe_runmake buildtest
 }
 
+do_install_append() {
+    oe_multilib_header nettle/nettle-stdint.h nettle/version.h
+}
+
 do_install_ptest() {
         install -d ${D}${PTEST_PATH}/testsuite/
         install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/