]> code.ossystems Code Review - openembedded-core.git/commitdiff
cronie: Convert crontab to a system user
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 9 Apr 2013 12:27:24 +0000 (13:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 May 2013 12:53:57 +0000 (13:53 +0100)
crontab is meant to be a system user, not a normal user of the system
so lets pass the correct parameters to the system. If we don't do this
it interferes with the setup of normal users, particularly if some
preset list of users is desired.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/cronie/cronie_1.4.9.bb

index 7db0381245d40689ea9afaf8e7813d672ce23526..b338c373ac34168788481bc5d749d2d76b179b47 100644 (file)
@@ -40,7 +40,7 @@ INITSCRIPT_NAME = "crond"
 INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
 
 USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "crontab"
+GROUPADD_PARAM_${PN} = "--system crontab"
 
 do_install_append () {
        install -d ${D}${sysconfdir}/sysconfig/