]> code.ossystems Code Review - openembedded-core.git/commitdiff
avahi: fix configure with automake 1.11.2
authorNitin A Kamble <nitin.a.kamble@intel.com>
Wed, 28 Dec 2011 19:59:52 +0000 (11:59 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 Jan 2012 12:10:47 +0000 (12:10 +0000)
automake version 1.11.2 has made use of dir variables more strict.
use of pkglibdir with DATA var results in automake errors.
  This commits uses pkgdatadir var instead of pkglibdir to avoid
the strict check errors.

Fixes this error:
service-type-database/Makefile.am:21: `pkglibdir' is not a legitimate
directory for `DATA'
autoreconf: automake failed with exit status: 1
ERROR: autoreconf execution failed.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-connectivity/avahi/avahi.inc
meta/recipes-connectivity/avahi/files/fix_for_automake_1.11.2.patch [new file with mode: 0644]

index deebbd6bb3bf85b0a5d21db892b77b550b57fd3e..3cee1a49782d6929176c25a8af4e57814a6df32e 100644 (file)
@@ -14,14 +14,15 @@ SECTION = "network"
 # python scripts are under GPLv2+
 LICENSE = "GPLv2+ & LGPLv2.1+"
 
-INC_PR = "r10"
+INC_PR = "r11"
 
 DEPENDS = "expat libcap libdaemon dbus glib-2.0"
 
 SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz \
           file://00avahi-autoipd \
           file://99avahi-autoipd \
-          file://initscript.patch"
+          file://initscript.patch \
+          file://fix_for_automake_1.11.2.patch"
 
 USERADD_PACKAGES = "avahi-daemon"
 USERADD_PARAM_avahi-daemon = "--system --home /var/run/avahi-daemon \
diff --git a/meta/recipes-connectivity/avahi/files/fix_for_automake_1.11.2.patch b/meta/recipes-connectivity/avahi/files/fix_for_automake_1.11.2.patch
new file mode 100644 (file)
index 0000000..e7a1908
--- /dev/null
@@ -0,0 +1,44 @@
+Upstream-Status: Pending
+
+automake version 1.11.2 has made use of dir variables more strict.
+the use of pkglibdir with DATA var results in automake errors.
+  This commits uses pkgdatadir var instead of pkglibdir to avoid 
+the strict check errors.
+
+Fixes this error:
+service-type-database/Makefile.am:21: `pkglibdir' is not a legitimate directory for `DATA'
+autoreconf: automake failed with exit status: 1
+ERROR: autoreconf execution failed.
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2011/12/28
+
+
+Index: avahi-0.6.30/service-type-database/Makefile.am
+===================================================================
+--- avahi-0.6.30.orig/service-type-database/Makefile.am
++++ avahi-0.6.30/service-type-database/Makefile.am
+@@ -18,13 +18,12 @@
+ EXTRA_DIST=build-db.in service-types
+ pkgdata_DATA=service-types
+-pkglib_DATA=
+ if HAVE_PYTHON
+ if HAVE_GDBM
+ noinst_SCRIPTS=build-db
+-pkglib_DATA+=service-types.db
++pkgdata_DATA+=service-types.db
+ build-db: build-db.in
+       $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \
+@@ -41,7 +40,7 @@ endif
+ if HAVE_DBM
+ noinst_SCRIPTS=build-db
+-pkglib_DATA+=service-types.db.pag service-types.db.dir
++pkgdata_DATA+=service-types.db.pag service-types.db.dir
+ build-db: build-db.in
+       $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \