]> code.ossystems Code Review - openembedded-core.git/commitdiff
libusb1: keep *.la in base_libdir
authorAndreas Müller <schnitzeltony@gmx.de>
Sun, 8 Jan 2012 18:04:08 +0000 (19:04 +0100)
committerSaul Wold <sgw@linux.intel.com>
Tue, 10 Jan 2012 05:51:49 +0000 (21:51 -0800)
This fixes the following error found during build from scratch for
meta-oe / obexd:

| arm-angstrom-linux-gnueabi-libtool: link: cannot find the library
| `/home/Superandy/tmp/oe-core-eglibc/sysroots/overo/lib/libusb-1.0.la' or
| unhandled argument `=/lib/libusb-1.0.la'

build-tested from scratch in angstrom environment.

Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
meta/recipes-support/libusb/libusb1_1.0.8.bb

index 5a921e0459d982027186817b9acefbd4d8780b17..8873de745a7a5c0011716d45593cdde022f994c3 100644 (file)
@@ -6,7 +6,7 @@ SECTION = "libs"
 LICENSE = "LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2"
 
@@ -20,7 +20,6 @@ EXTRA_OECONF = "--libdir=${base_libdir}"
 
 do_install_append() {
        install -d ${D}${libdir}
-       mv ${D}${base_libdir}/*.la ${D}${libdir}
        mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
 }