]> code.ossystems Code Review - openembedded-core.git/commitdiff
openjade: Fix configure assumptions about file moves
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Mar 2014 15:51:59 +0000 (15:51 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 5 Mar 2014 15:23:42 +0000 (15:23 +0000)
This means that do_configure prefunc code can see the files in question
and ensures aclocal files get copied in.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/openjade/openjade-native_1.3.2.bb

index 9dbd442207fdafe4d7cf8bda0ab48349395a8414..ccce421cf30df82f55da74038640dc1d1c9d9bc8 100644 (file)
@@ -42,9 +42,10 @@ SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
 SYSROOT_PREPROCESS_FUNCS += "openjade_sysroot_preprocess"
 
 # configure.in needs to be reloacted to trigger reautoconf
-do_configure_prepend () {
+do_extraunpack () {
        cp ${S}/config/configure.in ${S}/
 }
+addtask extraunpack after do_patch before do_configure
 
 # We need to do this else the source interdependencies aren't generated and
 # build failures can result (e.g. zero size style/Makefile.dep file)