]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: Fix externalsrc support
authorPaul Barker <pbarker@konsulko.com>
Mon, 9 Mar 2020 14:21:38 +0000 (14:21 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 Mar 2020 23:18:58 +0000 (23:18 +0000)
When the externalsrc class is used the tasks listed in
SRCTREECOVEREDTASKS are deleted to prevent them being executed. If
externalsrc is used for the kernel then this will include
virtual/kernel:do_patch.

We can depend on do_shared_workdir instead as this will survive when
externalsrc is used.

Signed-off-by: Paul Barker <pbarker@konsulko.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 10a5b88260d5fe8eb1646463b5afe0deacaa9a99..e005eb082b84706b16f04434f2af5aa4018fe563 100644 (file)
@@ -52,7 +52,7 @@ export PYTHON_SITEPACKAGES_DIR
 #kernel 3.1+ supports WERROR to disable warnings as errors
 export WERROR = "0"
 
-do_populate_lic[depends] += "virtual/kernel:do_patch"
+do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
 
 # needed for building the tools/perf Perl binding
 include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}