]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev-164: Update init script to do an explicit add action
authorKumar Gala <galak@kernel.crashing.org>
Wed, 2 Nov 2011 07:23:14 +0000 (02:23 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Nov 2011 14:03:36 +0000 (14:03 +0000)
With udev 152 or greater the default action for 'udevadm trigger' was
modified to be 'change' instead of 'add.

To ensure initial coldplug events at boot are seen be scripts the are
expecting them as 'add' events we invoke udevadm with an explicit
'--action=add'.

Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
meta/recipes-core/udev/udev-164/init
meta/recipes-core/udev/udev_164.bb

index 9ce95ee4c2b6a20354d5f8ea84b93a0d8678bb52..073942f27e7cb5eec16746c144f78b283928f1a3 100644 (file)
@@ -48,10 +48,10 @@ kill_udevd > "/dev/null" 2>&1
 
         /sbin/udevadm control --env=STARTUP=1
                if [ "$not_first_boot" != "" ];then
-                       /sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus  --subsystem-nomatch=graphics  --subsystem-nomatch=backlight --subsystem-nomatch=video4linux  --subsystem-nomatch=platform
+                       /sbin/udevadm trigger --action=add --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus  --subsystem-nomatch=graphics  --subsystem-nomatch=backlight --subsystem-nomatch=video4linux  --subsystem-nomatch=platform
                        (/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env=STARTUP=)&
                else
-                       /sbin/udevadm trigger
+                       /sbin/udevadm trigger --action=add
                        /sbin/udevadm settle
                fi
 
index 7cbe4d8b6074dde411b77a86a221869e4259dc14..d487addb600edf426dedf7d05d9a374d00b07db7 100644 (file)
@@ -1,6 +1,6 @@
 include udev-new.inc
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI += "file://udev-166-v4l1-1.patch"