]> code.ossystems Code Review - openembedded-core.git/commitdiff
yum: fix metadata
authorQing He <qing.he@intel.com>
Sat, 12 Jun 2010 07:59:32 +0000 (15:59 +0800)
committerJoshua Lock <josh@linux.intel.com>
Thu, 17 Jun 2010 22:16:40 +0000 (23:16 +0100)
update license and url
change to use new patch parameter

Signed-off-by: Qing He <qing.he@intel.com>
Signed-off-by: Kevin Tian <kevin.tian@intel.com>
meta/packages/yum/yum_3.2.27.bb

index 75669af448c42f5e9b782b66b662742e6a75c183..aff44ca6feb9a14f836979dd8fd3b01274d9f236 100644 (file)
@@ -1,12 +1,10 @@
-HOMEPAGE = "http://linux.duke.edu/projects/yum/"
-PR = "r8"
+DESCRIPTION = "yum package manger is an automatic updater for rpm."
+HOMEPAGE = "http://yum.baseurl.org/"
+BUGTRACKER = "http://yum.baseurl.org/report"
 
-SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
-           file://paths.patch;patch=1 \
-           file://paths2.patch;patch=1 \
-          file://yum-install-recommends.py \
-          file://extract-postinst.awk \
-          file://98_yum"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
+                    file://yum/sqlutils.py;beginline=2;endline=14;md5=d704ae6a9d69ce90768ab9188236b992"
 
 RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \
             python-shell python-re python-logging python-pickle \
@@ -15,6 +13,15 @@ RDEPENDS = "python-rpm python-core python-iniparse python-urlgrabber \
            python-textutils python-fcntl python-email \
            yum-metadata-parser"
 
+PR = "r8"
+
+SRC_URI = "http://yum.baseurl.org/download/3.2/yum-${PV}.tar.gz \
+           file://paths.patch;apply=yes \
+           file://paths2.patch;apply=yes \
+          file://yum-install-recommends.py \
+          file://extract-postinst.awk \
+          file://98_yum"
+
 S = "${WORKDIR}/yum-${PV}"
 
 inherit autotools
@@ -40,4 +47,4 @@ pkg_postinst_yum () {
 
 FILES_${PN} += "${libdir}/python* ${datadir}/yum-cli"
 
-BBCLASSEXTEND = "native"
\ No newline at end of file
+BBCLASSEXTEND = "native"