]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: update the ptest subdirs list
authorRandy MacLeod <Randy.MacLeod@windriver.com>
Tue, 14 May 2019 03:57:14 +0000 (23:57 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 15 May 2019 16:52:49 +0000 (17:52 +0100)
Split the list into one directory per line.
Sort the list alphabetically.
Add the gdbserver_tests directory to get the 'gone' executable
which is needed by:
    memcheck/tests/gone_abrt_xml.vgtest

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/valgrind/valgrind_3.15.0.bb

index 3b3d0f02f7ba7457d0dc43d078254c297e361476..5f95b5a740d748acc17433d235ceef5f80b50747 100644 (file)
@@ -136,7 +136,17 @@ do_install_ptest() {
         # exclude shell or the package won't install
         rm -rf none/tests/shell* 2>/dev/null
 
-        subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
+        subdirs=" \
+          cachegrind/tests \
+          callgrind/tests \
+          drd/tests \
+          gdbserver_tests \
+          helgrind/tests \
+          massif/tests \
+          memcheck/tests \
+          none/tests \
+          tests \
+       "
 
         # Get the vg test scripts, filters, and expected files
         for dir in $subdirs ; do