]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel: moves KERNEL_SRC_PATH to bitbake.conf
authorMing Liu <peter.x.liu@external.atlascopco.com>
Thu, 19 May 2016 11:05:50 +0000 (13:05 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 May 2016 21:31:35 +0000 (22:31 +0100)
"/usr/src/kernel" is being hard-coded in multiple recipes so far, move its
definition to bitbake.conf.

Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel.bbclass
meta/conf/bitbake.conf
meta/recipes-core/images/build-appliance-image_14.0.0.bb
meta/recipes-kernel/linux/kernel-devsrc.bb

index 6e3e81e936e13a91eb41e26e07fa9fae2c7cbce2..963f327dd6717c84e7d1589918d2e0d8fff3d815 100644 (file)
@@ -121,10 +121,6 @@ EXTRA_OEMAKE = ""
 
 KERNEL_ALT_IMAGETYPE ??= ""
 
-# Define where the kernel headers are installed on the target as well as where
-# they are staged.
-KERNEL_SRC_PATH = "/usr/src/kernel"
-
 copy_initramfs() {
        echo "Copying initramfs into ./usr ..."
        # In case the directory is not created yet from the first pass compile:
index 382dadca6dd15c9b4b97e39b03a745eb74f02d4b..8a84e53c1bf8802e1586f30bdd649ce2ec1eccd1 100644 (file)
@@ -407,6 +407,10 @@ OLDEST_KERNEL = "3.2.0"
 OLDEST_KERNEL_aarch64 = "3.14"
 OLDEST_KERNEL_nios2 = "3.19"
 
+# Define where the kernel headers are installed on the target as well as where
+# they are staged.
+KERNEL_SRC_PATH = "/usr/src/kernel"
+
 STAGING_KERNEL_DIR = "${TMPDIR}/work-shared/${MACHINE}/kernel-source"
 STAGING_KERNEL_BUILDDIR = "${TMPDIR}/work-shared/${MACHINE}/kernel-build-artifacts"
 
index 569fb3ae57f5533b203cbb37a026b565bbb40a2a..2a1a56b6177726ee5c04177411e03501cbe1057c 100644 (file)
@@ -54,7 +54,7 @@ fakeroot do_populate_poky_src () {
        cp ${WORKDIR}/README_VirtualBox_Guest_Additions.txt ${IMAGE_ROOTFS}/home/builder/
 
        # Create a symlink, needed for out-of-tree kernel modules build
-       ln -snr ${IMAGE_ROOTFS}/usr/src/kernel ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
+       ln -snr ${IMAGE_ROOTFS}${KERNEL_SRC_PATH} ${IMAGE_ROOTFS}/lib/modules/${KERNEL_VERSION}/build
 
        echo "/usr/bin" > ${IMAGE_ROOTFS}/home/builder/poky/build/pseudodone
        echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
index 196c8c7a24e2f8640cc0f4bec54b805a4c4e65c1..0fdd0ad5f633fab7b61e90c4f00de54614a76904 100644 (file)
@@ -28,9 +28,6 @@ do_configure[noexec] = "1"
 do_compile[noexec] = "1"
 do_populate_sysroot[noexec] = "1"
 
-# Define where the kernel headers are installed on the target as well as where
-# they are staged.
-KERNEL_SRC_PATH = "/usr/src/kernel"
 S = "${STAGING_KERNEL_DIR}"
 B = "${STAGING_KERNEL_BUILDDIR}"