]> code.ossystems Code Review - openembedded-core.git/commitdiff
taglib: use LIB_SUFFIX in order to determine the correct baselib
authorConstantin Musca <constantinx.musca@intel.com>
Mon, 4 Feb 2013 09:20:20 +0000 (11:20 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 4 Feb 2013 16:40:53 +0000 (16:40 +0000)
WARNING: QA Issue: taglib: Files/directories were installed but not shipped
  /usr/lib
  /usr/lib/libtag.so
  /usr/lib/libtag.so.1.12.0
  /usr/lib/libtag.so.1
  /usr/lib/libtag_c.so.0.0.0
  /usr/lib/libtag_c.so
  /usr/lib/libtag_c.so.0
  ...

Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/taglib/taglib_1.8.bb

index c713e438a8d29193ab5652aff6bf3486080f84da..76d2e519d5034335bf17bbed42bf8c5e2a286e3a 100644 (file)
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
                     file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
                     file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
 
-PR = "r0"
+PR = "r1"
 # http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz
 SRC_URI = "https://github.com/downloads/taglib/taglib/taglib-1.8.tar.gz \
            "
@@ -21,6 +21,8 @@ inherit cmake pkgconfig binconfig
 PACKAGES =+ "${PN}-c"
 FILES_${PN}-c = "${libdir}/libtag_c.so.*"
 
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
+
 do_configure_prepend () {
        rm -f ${S}/admin/ltmain.sh
        rm -f ${S}/admin/libtool.m4.in