]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: add PACKAGECONFIG for babeltrace
authorChen Qi <Qi.Chen@windriver.com>
Tue, 13 May 2014 02:54:26 +0000 (10:54 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 May 2014 12:42:10 +0000 (13:42 +0100)
Add PACKAGECONFIG for 'babeltrace' so that we don't have the implicit
dependency which might lead to problems when building images.

As an example of showing what problem we might have without this patch,
see the following steps which would lead to a failure.
1. IMAGE_INSTALL_append = " gdb"
2. bitbake babeltrace
3. bitbake gdb
4. bitbake babeltrace -ccleansstate
5. bitbake core-image-minimal

The rootfs process would fail with the following error message.
error: Can't install gdb-7.7-r0@i586: no package provides babeltrace >= 1.2.1+git0+66c2a20b43

(From OE-Core rev: 3c34d9391136b09bc2e7b0bda6cdc96507845c4b)

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gdb/gdb_7.6.2.bb

index e86447121b914f5e9292a19491bb2ebf3fdd43d2..7e8a4fdbdeed5127083f5d8d9e768e3438e04ec3 100644 (file)
@@ -5,6 +5,7 @@ inherit python-dir
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
 
 do_configure_prepend() {
        if [ -n "${@base_contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then