]> code.ossystems Code Review - openembedded-core.git/commitdiff
createrepo: Update to 0.9.9
authorSaul Wold <sgw@linux.intel.com>
Wed, 6 Apr 2011 22:15:56 +0000 (15:15 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 8 Apr 2011 13:07:46 +0000 (06:07 -0700)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/createrepo/createrepo/fix-native-install.patch
meta/recipes-support/createrepo/createrepo_0.9.9.bb [moved from meta/recipes-support/createrepo/createrepo_0.4.11.bb with 73% similarity]

index 2ed2202e7790df6812b1abc68aa42582d6a46065..53266b5444a5cf81ff8465a0d9fd6b4c794c6508 100644 (file)
@@ -4,19 +4,24 @@ There are two fixes:
   1. -native needs to customize prefix
   2. needs to change python reference in binaries
 
+Upstream-Status: Inappropriate [native]
+
 Signed-off-by: Qing He <qing.he@intel.com>
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
 
-diff --git a/Makefile b/Makefile
-index b2d1a32..3c3639f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -3,22 +3,22 @@ VERSION = 0.4.11
+Index: createrepo-0.9.9/Makefile
+===================================================================
+--- createrepo-0.9.9.orig/Makefile     2011-01-26 09:14:30.000000000 -0800
++++ createrepo-0.9.9/Makefile  2011-04-06 14:12:06.608923997 -0700
+@@ -10,22 +10,22 @@
  SHELL = /bin/sh
  top_srcdir = .
  srcdir = .
 -prefix = /usr
 -exec_prefix = ${prefix}
--
++prefix ?= /usr
++exec_prefix ?= ${prefix}
 -bindir = ${exec_prefix}/bin
 -sbindir = ${exec_prefix}/sbin
 -libexecdir = ${exec_prefix}/libexec
@@ -26,9 +31,6 @@ index b2d1a32..3c3639f 100644
 -localstatedir = ${prefix}/var
 -libdir = ${exec_prefix}/lib
 -infodir = ${prefix}/info
-+prefix ?= /usr
-+exec_prefix ?= ${prefix}
-+
 +bindir ?= ${exec_prefix}/bin
 +sbindir ?= ${exec_prefix}/sbin
 +libexecdir ?= ${exec_prefix}/libexec
@@ -45,19 +47,21 @@ index b2d1a32..3c3639f 100644
 -mandir = ${prefix}/share/man
 +mandir ?= ${prefix}/share/man
  
- pkgdatadir = $(datadir)/$(PACKAGE)
- pkglibdir = $(libdir)/$(PACKAGE)
-diff --git a/bin/Makefile b/bin/Makefile
-index 52c1f50..e30610e 100644
---- a/bin/Makefile
-+++ b/bin/Makefile
+ pkgdatadir = $(datadir)/$(PKGNAME)
+ pkglibdir = $(libdir)/$(PKGNAME)
+Index: createrepo-0.9.9/bin/Makefile
+===================================================================
+--- createrepo-0.9.9.orig/bin/Makefile 2011-01-26 09:14:30.000000000 -0800
++++ createrepo-0.9.9/bin/Makefile      2011-04-06 14:15:07.212923998 -0700
 @@ -1,22 +1,22 @@
  SHELL = /bin/sh
  top_srcdir = ..
  srcdir = ../bin
 -prefix = /usr
 -exec_prefix = ${prefix}
--
++prefix ?= /usr
++exec_prefix ?= ${prefix}
 -bindir = ${exec_prefix}/bin
 -sbindir = ${exec_prefix}/sbin
 -libexecdir = ${exec_prefix}/libexec
@@ -67,9 +71,6 @@ index 52c1f50..e30610e 100644
 -localstatedir = ${prefix}/var
 -libdir = ${exec_prefix}/lib
 -infodir = ${prefix}/info
-+prefix ?= /usr
-+exec_prefix ?= ${prefix}
-+
 +bindir ?= ${exec_prefix}/bin
 +sbindir ?= ${exec_prefix}/sbin
 +libexecdir ?= ${exec_prefix}/libexec
@@ -86,49 +87,55 @@ index 52c1f50..e30610e 100644
 -mandir = ${prefix}/man
 +mandir ?= ${prefix}/man
  
- pkgdatadir = $(datadir)/$(PACKAGE)
- pkglibdir = $(libdir)/$(PACKAGE)
-@@ -40,8 +40,11 @@ all: $(srcdir)/$(PACKAGE)
+ pkgdatadir = $(datadir)/$(PKGNAME)
+ pkglibdir = $(libdir)/$(PKGNAME)
+@@ -41,9 +41,14 @@
  
  
  install: all installdirs
--      $(INSTALL_BIN) $(srcdir)/$(PACKAGE) $(DESTDIR)$(bindir)/$(PACKAGE)
+-      $(INSTALL_BIN) $(srcdir)/$(PKGNAME) $(DESTDIR)$(bindir)/$(PKGNAME)
 -      $(INSTALL_BIN) $(srcdir)/modifyrepo $(DESTDIR)$(bindir)/modifyrepo
+-      $(INSTALL_BIN) $(srcdir)/mergerepo $(DESTDIR)$(bindir)/mergerepo
 +      sed -e "s|@DATADIR@|$(datadir)|" $(srcdir)/$(PACKAGE) > $(srcdir)/$(PACKAGE).tmp
 +      sed -e "s|@DATADIR@|$(datadir)|" $(srcdir)/modifyrepo > $(srcdir)/modifyrepo.tmp
++      sed -e "s|@DATADIR@|$(datadir)|" $(srcdir)/mergerepo > $(srcdir)/mergerepo.tmp
 +      $(INSTALL_BIN) $(srcdir)/$(PACKAGE).tmp $(DESTDIR)$(bindir)/$(PACKAGE)
 +      $(INSTALL_BIN) $(srcdir)/modifyrepo.tmp $(DESTDIR)$(bindir)/modifyrepo
-+      rm -f $(srcdir)/$(PACKAGE).tmp $(srcdir)/modifyrepo.tmp
++      $(INSTALL_BIN) $(srcdir)/mergerepo.tmp $(DESTDIR)$(bindir)/mergerepo
++      rm -f $(srcdir)/$(PACKAGE).tmp $(srcdir)/modifyrepo.tmp $(srcdir)/mergerepo.tmp
++
  
  
  uninstall:
-diff --git a/bin/createrepo b/bin/createrepo
-index b0de515..eaacb39 100755
---- a/bin/createrepo
-+++ b/bin/createrepo
+Index: createrepo-0.9.9/bin/createrepo
+===================================================================
+--- createrepo-0.9.9.orig/bin/createrepo       2011-01-26 09:14:30.000000000 -0800
++++ createrepo-0.9.9/bin/createrepo    2011-04-06 14:12:06.608923997 -0700
 @@ -1,2 +1,2 @@
  #!/bin/sh
 -exec /usr/share/createrepo/genpkgmetadata.py "$@"
 +exec @DATADIR@/createrepo/genpkgmetadata.py "$@"
-diff --git a/bin/modifyrepo b/bin/modifyrepo
-index c9732d8..6f7c1d4 100755
---- a/bin/modifyrepo
-+++ b/bin/modifyrepo
+Index: createrepo-0.9.9/bin/modifyrepo
+===================================================================
+--- createrepo-0.9.9.orig/bin/modifyrepo       2011-01-26 09:14:30.000000000 -0800
++++ createrepo-0.9.9/bin/modifyrepo    2011-04-06 14:12:06.608923997 -0700
 @@ -1,2 +1,2 @@
  #!/bin/sh
 -exec /usr/share/createrepo/modifyrepo.py "$@"
 +exec @DATADIR@/createrepo/modifyrepo.py "$@"
-diff --git a/docs/Makefile b/docs/Makefile
-index 0a41179..e128c85 100644
---- a/docs/Makefile
-+++ b/docs/Makefile
+Index: createrepo-0.9.9/docs/Makefile
+===================================================================
+--- createrepo-0.9.9.orig/docs/Makefile        2011-01-26 09:14:30.000000000 -0800
++++ createrepo-0.9.9/docs/Makefile     2011-04-06 14:12:06.608923997 -0700
 @@ -1,22 +1,22 @@
  SHELL = /bin/sh
  top_srcdir = ..
  srcdir = ../docs
 -prefix = /usr
 -exec_prefix = ${prefix}
--
++prefix ?= /usr
++exec_prefix ?= ${prefix}
 -bindir = ${exec_prefix}/bin
 -sbindir = ${exec_prefix}/sbin
 -libexecdir = ${exec_prefix}/libexec
@@ -138,9 +145,6 @@ index 0a41179..e128c85 100644
 -localstatedir = ${prefix}/var
 -libdir = ${exec_prefix}/lib
 -infodir = ${prefix}/info
-+prefix ?= /usr
-+exec_prefix ?= ${prefix}
-+
 +bindir ?= ${exec_prefix}/bin
 +sbindir ?= ${exec_prefix}/sbin
 +libexecdir ?= ${exec_prefix}/libexec
@@ -157,5 +161,5 @@ index 0a41179..e128c85 100644
 -mandir = ${datadir}/man
 +mandir ?= ${datadir}/man
  
- pkgdatadir = $(datadir)/$(PACKAGE)
- pkglibdir = $(libdir)/$(PACKAGE)
+ pkgdatadir = $(datadir)/$(PKGNAME)
+ pkglibdir = $(libdir)/$(PKGNAME)
similarity index 73%
rename from meta/recipes-support/createrepo/createrepo_0.4.11.bb
rename to meta/recipes-support/createrepo/createrepo_0.9.9.bb
index ba1d04b2bde1eff627d9a50e82b85d1064f9c28c..89f18f4e1c83e66b245bb25c2c70c0257e6e5ca2 100644 (file)
@@ -4,14 +4,13 @@ HOMEPAGE = "http://createrepo.baseurl.org/"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
 
-PR = "r1"
+PR = "r0"
 
 SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
           file://fix-native-install.patch \
          "
-
-SRC_URI[md5sum] = "3e9ccf4abcffe3f49af078c83611eda2"
-SRC_URI[sha256sum] = "a73ae11a0dcde8bde36d900bc3f7f8f1083ba752c70a5c61b72d1e1e7608f21b"
+SRC_URI[md5sum] = "10641f19a40e9f633b300e23dde00349"
+SRC_URI[sha256sum] = "ee897463837b299fb20bf6e970f8c5324cd8b7f26ad3675a9938a2d7ae42ff03"
 
 BBCLASSEXTEND = "native"