]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel.bbclass: Add kernel_version_sanity_check function
authorCalifornia Sullivan <california.l.sullivan@intel.com>
Fri, 16 Sep 2016 23:48:24 +0000 (16:48 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Sep 2016 19:18:32 +0000 (20:18 +0100)
The kernel being built should match what the recipe claims it is
building. This function ensures that happens by comparing the version
information in the kernel's Makefile to the PV the recipe is using.

v2 changes:
* Match against PV instead of LINUX_VERSION
* Match against EXTRAVERSION as well (e.g., -rc4)
* Cleaned up version string building

Fixes [YOCTO #6767].

Signed-off-by: California Sullivan <california.l.sullivan@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel.bbclass
meta/recipes-kernel/linux/linux-yocto.inc

index bfb7350604da82c2f4de68002a356634af1c0c8f..25a153cd2042d3a4b21d78efd921a8fccfd7914c 100644 (file)
@@ -327,6 +327,36 @@ kernel_do_install() {
 }
 do_install[prefuncs] += "package_get_auto_pr"
 
+# Must be ran no earlier than after do_kernel_checkout or else Makefile won't be in ${S}/Makefile
+do_kernel_version_sanity_check() {
+       # The Makefile determines the kernel version shown at runtime
+       # Don't use KERNEL_VERSION because the headers it grabs the version from aren't generated until do_compile
+       VERSION=$(grep "^VERSION =" ${S}/Makefile | sed s/.*=\ *//)
+       PATCHLEVEL=$(grep "^PATCHLEVEL =" ${S}/Makefile | sed s/.*=\ *//)
+       SUBLEVEL=$(grep "^SUBLEVEL =" ${S}/Makefile | sed s/.*=\ *//)
+       EXTRAVERSION=$(grep "^EXTRAVERSION =" ${S}/Makefile | sed s/.*=\ *//)
+
+       # Build a string for regex and a plain version string
+       reg="^${VERSION}\.${PATCHLEVEL}"
+       vers="${VERSION}.${PATCHLEVEL}"
+       if [ -n "${SUBLEVEL}" ]; then
+               # Ignoring a SUBLEVEL of zero is fine
+               if [ "${SUBLEVEL}" = "0" ]; then
+                       reg="${reg}(\.${SUBLEVEL})?"
+               else
+                       reg="${reg}\.${SUBLEVEL}"
+                       vers="${vers}.${SUBLEVEL}"
+               fi
+       fi
+       vers="${vers}${EXTRAVERSION}"
+       reg="${reg}${EXTRAVERSION}"
+
+       if [ -z `echo ${PV} | grep -E "${reg}"` ]; then
+               bbfatal "Package Version (${PV}) does not match of kernel being built (${vers}). Please update the PV variable to match the kernel source."
+       fi
+       exit 0
+}
+
 addtask shared_workdir after do_compile before do_compile_kernelmodules
 addtask shared_workdir_setscene
 
index 98a48ec44a641f2608105e6a035e704514fd2f18..d979662a500b1d94b75fd78a4414a69da1ac6394 100644 (file)
@@ -55,6 +55,7 @@ do_install_append(){
 }
 
 # extra tasks
+addtask kernel_version_sanity_check after do_kernel_checkout before do_compile
 addtask kernel_link_images after do_compile before do_install
 addtask validate_branches before do_patch after do_kernel_checkout
 addtask kernel_configcheck after do_configure before do_compile