]> code.ossystems Code Review - openembedded-core.git/commitdiff
rust-native: Avoid stripped warning
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 23 Aug 2021 12:59:23 +0000 (13:59 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Aug 2021 21:09:24 +0000 (22:09 +0100)
Instead of giving the following warning, hide it since we don't plan to change it.

WARNING: rust-native-1.54.0-r0 do_populate_sysroot: File '/media/build1/poky/build/tmp/work/x86_64-linux/rust-native/1.54.0-r0/recipe-sysroot-native/usr/lib/rustlib/x86_64-linux/bin/rust-llvm-dwp' from rust-native was already stripped, this will prevent future debugging!

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rust/rust_1.54.0.bb

index 07221ac1277ad0c39d6b56275223e06f2a27405b..ee60c3e6f1e809c32203aab347ac51b1b4a02e4c 100644 (file)
@@ -2,6 +2,8 @@ require rust-target.inc
 require rust-source-${PV}.inc
 require rust-snapshot-${PV}.inc
 
+INSANE_SKIP:${PN}:class-native = "already-stripped"
+
 do_compile () {
     rust_runx build --stage 2
 }