]> code.ossystems Code Review - openembedded-core.git/commitdiff
eds: make eds-dbus-dev recommend libecal-dev libebook-dev
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 3 Dec 2007 12:57:14 +0000 (12:57 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 3 Dec 2007 12:57:14 +0000 (12:57 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3298 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/eds/eds-dbus_svn.bb

index 16d0dece331b1c2a0687027d700b61af780ed0e0..b7fa63f4dbdc68ef156c017a0099a7b5657b1ff1 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "LGPL"
 DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libiconv zlib"
 
 PV = "1.4.0+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
            file://oh-contact.patch;patch=1;pnum=0 \
@@ -21,7 +21,11 @@ inherit autotools pkgconfig
 LDFLAGS += "-lpthread"
 
 do_configure_append () {
-    cp ${WORKDIR}/iconv-detect.h ${S}
+        cp ${WORKDIR}/iconv-detect.h ${S}
+}
+
+do_stage () {
+        autotools_stage_all
 }
 
 EXTRA_OECONF = "--without-openldap --with-dbus --without-bug-buddy \
@@ -36,6 +40,7 @@ PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
 FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
 FILES_${PN}-dbg =+ "${libdir}/evolution-data-server-*/camel-providers/.debug \
                     ${libdir}/evolution-data-server*/extensions/.debug/"
+RRECOMMENDS_${PN}-dev += "libecal-dev libebook-dev"
 
 FILES_libcamel = "${libexecdir}/camel-* ${libdir}/libcamel-*.so.* \
                   ${libdir}/libcamel-provider-*.so.* \
@@ -79,6 +84,3 @@ FILES_libedataserver-dev = "${libdir}/libedataserver-*.so \
                             ${libdir}/pkgconfig/libedataserver-*.pc \
                             ${includedir}/evolution-data-server-*/libedataserver/*.h"
 
-do_stage () {
-        autotools_stage_all
-}