]> code.ossystems Code Review - openembedded-core.git/commitdiff
Revert "quilt: fix patch version detection"
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Feb 2011 17:34:59 +0000 (17:34 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 1 Feb 2011 17:34:59 +0000 (17:34 +0000)
This reverts commit bc31351f6989372c7feb403f23532afd1f510fb1.

This change is already applied against configure, not configure.ac. This change forces a
reautoconf of quilt-native before we've built autoconf and if "git-desc" isn't present it
can result in further problems. The simplest solution is to revert this change.

meta/recipes-devtools/quilt/quilt-native_0.48.bb
meta/recipes-devtools/quilt/quilt.inc
meta/recipes-devtools/quilt/quilt/patch-version-detection.patch [deleted file]
meta/recipes-devtools/quilt/quilt_0.48.bb

index 3cfe3959c5108f9eb1d602c4f708e87b058a5f06..a62531e39d0e754c8f3935e6580ded37acbc6431 100644 (file)
@@ -1,7 +1,7 @@
 require quilt.inc
 require quilt-native.inc
 
-PR = "r1"
+PR = "r0"
 
 SRC_URI[md5sum] = "f77adda60039ffa753f3c584a286f12b"
 SRC_URI[sha256sum] = "73fd760d3b5cbf06417576591dc37d67380d189392db9000c21b7cbebee49ffc"
index e2cfce4a065b71cb3c28627872075ec5f78a35a2..45425116af50ad985588b414442e6be698e42946 100644 (file)
@@ -6,8 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
 SRC_URI = "http://download.savannah.gnu.org/releases/quilt/quilt-${PV}.tar.gz \
         file://install.patch \
-        file://gnu_patch_test_fix.patch \
-        file://patch-version-detection.patch"
+        file://gnu_patch_test_fix.patch"
 
 inherit autotools
 
diff --git a/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch b/meta/recipes-devtools/quilt/quilt/patch-version-detection.patch
deleted file mode 100644 (file)
index 8b84f81..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From: Jean Delvare
-Subject: [Quilt-dev] [PACH] Fix patch version detection
-Date: Mon, 21 Jun 2010 13:49:50 +0200
-
-New versions of GNU patch present themselves as "GNU patch" instead
-of just "patch".
----
- configure.ac |    6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -262,7 +262,11 @@ fi
- AC_MSG_CHECKING([the version of $PATCH])
- if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
-   set -- `$PATCH --version 2> /dev/null`
--  patch_version=$2
-+  if test x$1 = xGNU ; then
-+    patch_version=$3
-+  else
-+    patch_version=$2
-+  fi
-   AC_MSG_RESULT($patch_version)
-   saved_IFS=$IFS; IFS='.'
-   set -- $patch_version
-
--- 
-Jean Delvare
-Suse L3
index 6f5e2bc10f477884441b37625ed1a22dabcb4e40..a2a8a5ce344858b05094bb60968a32321ff9c6a4 100644 (file)
@@ -2,7 +2,7 @@ require quilt.inc
 LICENSE="GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 RDEPENDS_${PN} += "patch diffstat bzip2 util-linux"
-PR = "r1"
+PR = "r0"
 SRC_URI += "file://aclocal.patch"
 
 SRC_URI[md5sum] = "f77adda60039ffa753f3c584a286f12b"