]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: Enable gudev
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 29 Jan 2010 15:18:56 +0000 (15:18 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 29 Jan 2010 15:18:56 +0000 (15:18 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/udev/udev-145/enable-gudev.patch [new file with mode: 0644]
meta/packages/udev/udev_145.bb

diff --git a/meta/packages/udev/udev-145/enable-gudev.patch b/meta/packages/udev/udev-145/enable-gudev.patch
new file mode 100644 (file)
index 0000000..45fd373
--- /dev/null
@@ -0,0 +1,48 @@
+Index: udev-145/configure.ac
+===================================================================
+--- udev-145.orig/configure.ac 2010-01-29 14:41:29.000000000 +0000
++++ udev-145/configure.ac      2010-01-29 14:41:54.000000000 +0000
+@@ -49,16 +49,17 @@
+ AC_ARG_ENABLE([extras],
+       AS_HELP_STRING([--disable-extras], [disable extras with external dependencies]),
+       [], [enable_extras=yes])
++
++      PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
++      AC_SUBST([GLIB_CFLAGS])
++      AC_SUBST([GLIB_LIBS])
++
+ if test "x$enable_extras" = xyes; then
+       AC_PATH_PROG([GPERF], [gperf])
+       if test -z "$GPERF"; then
+               AC_MSG_ERROR([gperf is needed])
+       fi
+-      PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0])
+-      AC_SUBST([GLIB_CFLAGS])
+-      AC_SUBST([GLIB_LIBS])
+-
+       AC_CHECK_LIB([acl], [acl_init], [:], AC_MSG_ERROR([libacl not found]))
+       AC_CHECK_HEADER([acl/libacl.h], [:], AC_MSG_ERROR([libacl header not found]))
+Index: udev-145/extras/Makefile.am
+===================================================================
+--- udev-145.orig/extras/Makefile.am   2010-01-29 14:43:56.000000000 +0000
++++ udev-145/extras/Makefile.am        2010-01-29 14:44:11.000000000 +0000
+@@ -12,7 +12,8 @@
+       rule_generator \
+       scsi_id \
+       usb_id \
+-      v4l_id
++      v4l_id \
++      gudev 
+ if ENABLE_EXTRAS
+ SUBDIRS += \
+@@ -20,6 +21,5 @@
+       usb-db \
+       hid2hci \
+       keymap \
+-      modem-modeswitch \
+-      gudev
++      modem-modeswitch
+ endif
index ab5d3fe458c58039b669ca050a1eaf5504922eec..e1a2938e1764a00a92b2dab620694334df917a5f 100644 (file)
@@ -3,9 +3,10 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 RPROVIDES_${PN} = "hotplug"
 
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+           file://enable-gudev.patch;patch=1 \
           file://run.rules \
           "
 
@@ -20,7 +21,7 @@ FILES_${PN} += "${base_libdir}/udev/*"
 FILES_${PN}-dbg += "${base_libdir}/udev/.debug"
 UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/"
 
-EXTRA_OECONF = "--with-udev-prefix= --disable-extras"
+EXTRA_OECONF = "--with-udev-prefix= --disable-extras --disable-introspection"
 
 do_install () {
        install -d ${D}${usrsbindir} \